Closed Bug 441035 Opened 14 years ago Closed 14 years ago

If a Firefox profile is started with --profilemanager --no-remote parameter, external links can't opened with that profile

Categories

(Firefox :: Shell Integration, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED INVALID

People

(Reporter: cjcypoi02, Unassigned)

References

Details

(Keywords: ue)

Steps to reproduce:

1) download and install the latest Fx trunk
2) create a shortcut to Fx with '--profilemanager --no-remote' parameters
3) open the link
4) select a profile, deselect 'Don't ask at startup' and start Fx
5) try to open a local page or a link from another app. Profile Manager must be shown
6) select the profile already in use and try to start

Actual result:
Profile Manager tries to start another Fx process using the same profile, but this is not possible because it's already in use

Expected result:
the page or the link should be opened in a new tab of an already existing window of that profile.


Please someone can test this bug also on Linux and Mac?
That is precisely what --no-remote does. "can open more than one profile at a time if you do this" is just a side-effect of "ignore requests from other applications to open URLs."
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
So --no-remote means 'don't allow remote executions'?

Well, so what I must do? I would simply to choice the profile to use every time and the ability to open more profiles at the same time. I must use two shortcut, one with --profilemanager and one with --profilemanager -no-remote? It seems to me a mess.

Why simply --profilemanager don't allow you to open multiple profiles? Blocking remote executions is so essential?
(In reply to comment #2)
> So --no-remote means 'don't allow remote executions'?
aka OS Integration

> Well, so what I must do? I would simply to choice the profile to use every time
> and the ability to open more profiles at the same time. I must use two
> shortcut, one with --profilemanager and one with --profilemanager -no-remote?
> It seems to me a mess.
To use the same profile from outside of the application (e.g. launching an url from an external app or the OS) you must use OS Integration and not use -no-remote or any of the other methods used to disable OS Integration.
 
> Why simply --profilemanager don't allow you to open multiple profiles? Blocking
> remote executions is so essential?
Many of the profile files can only be accessed from one process because accessing them from multiple processes will cause corruption of the profile data.
(In reply to comment #3)
> Many of the profile files can only be accessed from one process because
> accessing them from multiple processes will cause corruption of the profile
> data.

This is correct, but I don't want Fx creates a new process. I think simply Firefox should open the url with the existing process in a new tab, if the process already exists.
Then you shouldn't be specifying -no-remote which provides this functionality per

"To use the same profile from outside of the application (e.g. launching an url from an external app or the OS) you must use OS Integration and not use -no-remote or any of the other methods used to disable OS Integration."
Well, I opened another bug, Bug 441035. I think this time I reported the request correctly :-)
Uops, the correct link is Bug 441422.
Status: RESOLVED → VERIFIED
The problem that I had with the profile manager was that it would NOT open Firefox at all from email or other links. If I did not use profile manager Fx 3 worked great!
This is why I'm still using Firefox 2.xx
Duplicate of this bug: 634547
Duplicate of this bug: 1502453
You need to log in before you can comment on or make changes to this bug.