External links don't open (even if Firefox is set as the default browser) when a Firefox instance is already launched with the -no-remote switch.

RESOLVED DUPLICATE of bug 441035

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 441035
7 years ago
7 years ago

People

(Reporter: klonos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I believe that the issue's title says it all. If one sets their firefox shortcut to start firefox with the "-no-remote" switch (in order to be able to launch multiple profiles in the same host OS), then external links from other applications or URL shortcuts do not open in firefox. An error pops up instead asking the user to close firefox:

"Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

PS: I hope I've chosen the right component to file this issue under. If not, then feel free to change it to the correct one. Also, setting this to "All" for hardware and OS, since I see this in at least WinXP x86 and Win7 x64.
(Reporter)

Updated

7 years ago
Summary: External links don't open even if Firefox is set as the default browser when fired with the -no-remote switch → External links don't open (even if Firefox is set as the default browser) when a Firefox instance is already launched with the -no-remote switch.

Comment 1

7 years ago
bug 325509 implemented it literally "to disable remote stuff" which would include external links from other applications.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441035
You need to log in before you can comment on or make changes to this bug.