any attempt to print crashes Firefox

RESOLVED DUPLICATE of bug 422916

Status

()

--
critical
RESOLVED DUPLICATE of bug 422916
10 years ago
10 years ago

People

(Reporter: chris.janman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0) Gecko/2008061600 SUSE/3.0-1.1 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0) Gecko/2008061600 SUSE/3.0-1.1 Firefox/3.0

try to print (Ctrl-P or from File menu) causes Print Dialog box frame to appear, sometimes a printer name appears, then Firefox crashes.  Bug-buddy reports that gecko crashed. Occurs on any page, even a blank one.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Try to print.
3.
Actual Results:  
Bug-buddy reports crash in gecko & Firefox window disappears.

Expected Results:  
Print dialog box

OpenSuSE 10.2
KDE 3.?
Default theme
En-GB dictionary installed.
ABP installed.

Comment 1

10 years ago
Can you reproduce the crash in a mozilla.com build?
http://www.mozilla.com/

Comment 2

10 years ago
I have also noticed the same bug (and try to signal it on https://bugzilla.mozilla.org/show_bug.cgi?id=439861, which might be a similar bug).

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

(I believe this is a mozilla.com built: this is the one I downloaded from mozilla.cpom when 3.0 was released).

Comment 3

10 years ago
I have firefox 3.0 (mozilla.com build) crashing EVERY time I print. either the print menu or a "window.print()" js call..  No dialog appears mozilla just crashes, and the crash reporting tool continually fails to submit crash reports.

I'm running the 32-bit linux FF 3 mozilla.com build on a Fedora 8 x86_64 gnu/linux install.
I'm pretty sure that is a dupe of bug 422916.
openSUSE users might want to check out
http://en.opensuse.org/Firefox:Firefox3FAQ#Known_issues

I'm not sure if Fedora 8 has the same issue. The other bug says Fedora 6 was affected though.
(Reporter)

Comment 5

10 years ago
Wolfgang's GTK2 fix fixed the problem for me under openSUSE 10.2.  Thank you!

Comment 6

10 years ago
I still have the problem with OpenSUSE 10.3 and FireFox 3.0.1. Any time the printing pop-up box appears (prieview or printing and print setup) FireFox 3.0.1 crashes.

gtk2 is newest in OpenSUSE repo:
rpm -q --qf '%{name}-%{version}-%{release}-%{distribution}\n' gtk2
gtk2-2.12.0-5.8-openSUSE 10.3 (X86-64)

uname -a
Linux 2.6.22.18-0.2-default #1 SMP 2008-06-09 13:53:20 +0200 x86_64 x86_64 x86_64 GNU/Linux

FireFox:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-2.1 Firefox/3.0.1

Comment 7

10 years ago
Bug seems the same as https://bugzilla.novell.com/show_bug.cgi?id=374554
(In reply to comment #7)
> Bug seems the same as https://bugzilla.novell.com/show_bug.cgi?id=374554
> 

If that's the case, then this bug is a dupe of bug 422916, which, BTW, is not a Mozilla bug but a GTK/Gnome bug; and if you still experience the problem on openSUSE 11.0 (not 10.3), which is the current public release, then you may want to make sure that the Novell bug and/or the Gnome bug https://bugzilla.gnome.org/show_bug.cgi?id=482531 are REOPENED. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422916

Comment 9

10 years ago
Look at my reply #6 above reply #7. It was added after I found it at
https://bugzilla.novell.com/show_bug.cgi?id=374554 as well.


Please note that bug 422916 and https://bugzilla.gnome.org/show_bug.cgi?id=482531 have different reasons.
This looks like the referenced Gnome bug since the other one doesn't affect gtk 2.12.x
You need to log in before you can comment on or make changes to this bug.