Firefox starts in offline mode everytime, but there is an internet connection available

RESOLVED DUPLICATE of bug 424626

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 424626
9 years ago
9 years ago

People

(Reporter: markusd112, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9) Gecko/2008061015 Firefox/3.0

Since FF3 firefox starts in offline mode and I have to change the state to online mode manually. It's very very annoying.

There is an internet connection available. It is started via a shell script (UMTS).

And I cannot switch off the automatic online detection of FF.

Reproducible: Always

Steps to Reproduce:
1. Establish internet connection via shellscript (wvdial)
2. start firefox
3. Firefox is in offline mode
Actual Results:  
Firefox is in offline mode

Expected Results:  
firefox should be always in online mode, maybe a possibility to activate the automatism

Comment 1

9 years ago
Please try the command mentioned in bug 441491 before and after you establish a connection. If NetworkManager is reporting a disconnected status in both cases, the issue is with NetworkManager and not Firefox. In that case, you can  investigate and report it upstream and report the status here for reference.
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

9 years ago
I don't know, what the result of the command means, but here it is:

Offline:
method return sender=:1.0 -> dest=:1.61 reply_serial=2
   uint32 4

Online:
method return sender=:1.0 -> dest=:1.62 reply_serial=2
   uint32 4

Comment 3

9 years ago
Thanks for your quick feedback. The meaning of the return value is:

typedef enum NMState
{
        NM_STATE_UNKNOWN = 0,
        NM_STATE_ASLEEP,
        NM_STATE_CONNECTING,
        NM_STATE_CONNECTED,
        NM_STATE_DISCONNECTED
} NMState;

So a value of 4 means NetworkManager thinks the network is not connected both cases. I don't know NetworkManager very well, but I guess it does not take the ppp interface into account when you connect using wwwvdial to advertise that the network is up. Please look in NetworkManager/your distribution bug tracking/forums if this issue is reported and report your findings here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

9 years ago
The problem occurs since version 3 of Firefox, so it seemed to be a bug in FF3. In FF2 everything worked fine. I don't use any NetworkManager and Firefox shall only access the existing network connecting and shouldn't try to find out if there is any connection in a wrong way. Maybe a simple try to connect to an internetaddress could check the availability of a connection to instead of using some "NetworkManager"...

It's very very annoying since version 3 of firefox!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

9 years ago
This bug does also occur on my sytem (Debian lenny). It is very annoying and there should be a way to turn this behavior off. I did never use Network Manager and I don't want to use it, so please make it possible to turn this "feature" off.
Flags: blocking-firefox3.1?

Comment 6

9 years ago
It is possible to turn it off. Set toolkit.networkmanager.disable to true in about:config.

Comment 7

9 years ago
Dominik, Firefox shouldn't start in offline if you have no NetworkManager service running. Otherwise, this is a bug that needs to be addressed.

Can you try to run the command (as root):

dbus-send --print-reply --system --dest=org.freedesktop.NetworkManager --type=method_call /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.state

And report the result? If it returns 4 and you have network connectivity, then the trouble is that NetworkManager is not detecting your connection correctly (are you using dial-up or a 3G card?).
(Reporter)

Comment 8

9 years ago
I have entered about:config as URL and searched for the key "toolkit.networkmanager.disable", but this key doesn't exist. So I created a new one and set it to "true", but FF starts still in offline mode, when an UMTS connection has been established via wvdial...

Comment 9

9 years ago
Sorry the pref has not yet landed on branch. I found the relevant bug now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424626

Updated

9 years ago
Flags: blocking-firefox3.1?
You need to log in before you can comment on or make changes to this bug.