Closed Bug 441531 Opened 14 years ago Closed 13 years ago

Port |Bug 83968 – Ability to specify whether to search online or offline| to Thunderbird; and improve (common) UI

Categories

(MailNews Core :: Search, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 441340

People

(Reporter: sgautherie, Unassigned)

References

Details

Attachments

(1 file)

Per bug 441077 comment 4:
{{
SeaMonkey has: bug 83968 (Allow local searches even when online)
}}

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008062301 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008062303 Thunderbird/3.0a2pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008062303 Thunderbird/3.0a2pre] (nightly) (W2Ksp4)
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #326481 - Flags: review?(bugzilla)
Comment on attachment 326481 [details] [diff] [review]
(Av1) <SearchDialog.*>

So this patch works, but I really don't like the UI.

At a quick glance "Search local system" would imply to me that Thunderbird would search your local system (i.e. all your data files, not just Thunderbirds).

On second glance, I'd probably just be confused as what is my local system?

Then I go into offline, and that check box has no effect whatsoever (because Thunderbird automatically searches the local system).

IMHO this is a good feature improvement because you can do searching in news groups using offline/cached store, but the UI is really bad.

Requesting ui-review from Bryan to see what he thinks.
Attachment #326481 - Flags: ui-review?(clarkbw)
(In reply to comment #2)

I didn't look at it in details, but I concur:
that's +/- how/what I felt when I tried this feature when testing.

Current or better ui would be fine with me, as long as it's common/sync'ed to SM and TB ;-)
Comment on attachment 326481 [details] [diff] [review]
(Av1) <SearchDialog.*>

Yeah, I think this option would be a bit confusing.  It seems like the intended behavior would be to automatically search locally when online search isn't available.  The primary intention of the person is to search the newsgroup, online or offline searching is only a good option when the other search doesn't work.  

So the behavior I see that we'll get is that people attempt a search without this option checked and receive the XPAT error dialog.  Then the person will have to understand to check the box and search locally instead.  If it's possible to detect XPAT one could offer that we setup the checked default based on that; however at that point we're being automatic and still confusing.

If our offline search was really good then I'd say a better direction to move in is one where we always search locally and give some kind of info bar notification that we just searched locally with an option to search online as well.
Attachment #326481 - Flags: ui-review?(clarkbw) → ui-review-
Comment on attachment 326481 [details] [diff] [review]
(Av1) <SearchDialog.*>

per Bryan's comments.
Attachment #326481 - Flags: review?(bugzilla) → review-
Product: Core → MailNews Core
Unassigning myself, for now.

"blocking‑thunderbird3.0b1=?":
This bug seems to be "blocking" others and may need updated strings.
Assignee: sgautherie.bz → nobody
Severity: trivial → normal
Status: ASSIGNED → NEW
Flags: blocking-thunderbird3.0b1?
Keywords: helpwanted
Summary: Port |Bug 83968 – Ability to specify whether to search online or offline| to Thunderbird → Port |Bug 83968 – Ability to specify whether to search online or offline| to Thunderbird; and improve (common) UI
Target Milestone: mozilla1.9.1a1 → ---
This doesn't block the release. I think if you want to proceed with unforking the files, this is one case where an ifdef in the xul would be acceptable (SearchDialog.js would then have to detect if its available or not). I certainly doubt that we'll get to a different reasonable solution on this in a short time scale.
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1-
I found this bug after I discovered that SM has the local search option, that TB really needs. This is an important bug for IMAP, because in TB3 the capabilities of local search are expanded, plus this dialog is a precursor to the virtual folders dialog, which does have the option to choose offline or online search already.

So I'd like to pursue a simple solution to this. What if we abandon for now the attempt to unfork, and add to the search dialog the same option that we have in the New Saved Search Folder dialog "Search Online (Gives up-to-date results for IMAP and News folders but increases time to open the folder)"
Assignee: nobody → kent
Status: NEW → ASSIGNED
Blocks: 370125
(In reply to comment #8)
> So I'd like to pursue a simple solution to this. What if we abandon for now the
> attempt to unfork, and add to the search dialog the same option that we have in
> the New Saved Search Folder dialog "Search Online (Gives up-to-date results for
> IMAP and News folders but increases time to open the folder)"

That sounds reasonable
The suggestion in comment 9 has now landed in bug 511131. So the first part of this bug's request "Ability to specify whether to search online or offline| to Thunderbird" has been fixed. The second part remains, which I interpret as unforking the UI dialogs for the SM and TB search screens. But that is bug 441340. So I'm going to unassign myself from this, and dupe it.
Assignee: kent → nobody
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: helpwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 441340
You need to log in before you can comment on or make changes to this bug.