Last Comment Bug 441649 - Firefox 3.0 Crash Report [@ nsBaseWidget::RemoveChild(nsIWidget*) ] - metasearch addon
: Firefox 3.0 Crash Report [@ nsBaseWidget::RemoveChild(nsIWidget*) ] - metase...
Status: RESOLVED FIXED
: topcrash+
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Justin Scott [:fligtar]
:
Mentors:
: 441276 (view as bug list)
Depends on: 423968 444124
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 14:19 PDT by chris hofmann
Modified: 2016-03-07 15:30 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
blocklist xml after SQL applied (1.62 KB, application/xml)
2008-06-25 00:29 PDT, Justin Scott [:fligtar]
morgamic: review+
Details
mozilla.com blocklist patch (869 bytes, patch)
2008-06-25 00:42 PDT, Justin Scott [:fligtar]
morgamic: review+
Details | Diff | Splinter Review
Bug 441649 - Firefox 3.0 Crash Report [@ nsBaseWidget::RemoveChild(nsIWidget*) ] - metasearch addon (deleted)
2009-05-03 12:30 PDT, Rowdy
no flags Details

Description chris hofmann 2008-06-24 14:19:04 PDT
ted spotted this topcrash on firefox 3 after database clean up work

0  	xul.dll  	nsBaseWidget::RemoveChild  	 mozilla/widget/src/xpwidgets/nsBaseWidget.cpp:345
1 	xsupport.dll 	xsupport.dll@0x114d 	
2 	xul.dll 	XPCWrappedNative::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2393
3 	xul.dll 	XPC_WN_CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1473
4 	js3250.dll 	js_Invoke 	mozilla/js/src/jsinterp.c:1297
5 	js3250.dll 	js_Interpret 	mozilla/js/src/jsinterp.c:4852
6 	js3250.dll 	js_Invoke 	mozilla/js/src/jsinterp.c:1313
7 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1523
8 	xul.dll 	nsXPCWrappedJS::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:559
9 	xul.dll 	PrepareAndDispatch 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
10 	xul.dll 	SharedStub 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
11 	xul.dll 	nsEventListenerManager::HandleEventSubType 	mozilla/content/events/src/nsEventListenerManager.cpp:1080

all of he reports seem to showing binary components from this extension

http://www.crawler.com/products/toolbar.aspx

and users don't have a clue about what is causing their startup crash..  comements:

> will not start up don't know what the problem is.

> Unable to access web via Mizilla Firefox 3.0 due to crashes. Can ony access web by using "safe mode."

> STOP THIS MADNESS! I USED TO LOVE FIREFOX BUT NOT ANYMORE! This stupid screen has poped up for 3 days! Do not make me go back to Internet Explorer!

a quick scan of several reports shows that all crashes may be associated with

xshared.dll  	1.0.0.42

here is what prevx has to say about the .dll that appears related to the crash


http://www.prevx.com/filenames/2114591682775330811-0/XSHARED.DLL.html

What we know about XSHARED.DLL:
The filename XSHARED.DLL was first seen on May 28 2008 in SPAIN. It has also been seen in the following geographical regions of the Prevx community:

    * The UNITED STATES on Jun 2 2008
    * The EUROPEAN UNION on Jun 2 2008

The filename XSHARED.DLL is used by multiple object types including Dynamic Link LIbraries,objects.
The most common file size is 343,552 bytes. But the following file sizes have also been seen:

    * 361,984 bytes
    * 1,167,964,050 bytes

These files may have the following Vendor, Product, Version Information in the file header Crawler.com; Crawler Firefox Shared Library;

    * The following Vendor, Product, Version Information has also been reported:

Crawler.com; Crawler Firefox Shared Library; 1.0.0.42
XSHARED.DLL has been seen to perform the following behavior(s):

    * The Process is polymorphic and can change its structure

XSHARED.DLL has been the subject of the following behavior(s):

    * Created as a process on disk
    * Deleted as a process from disk
    * Registered as a Dynamic Link Library File

XSHARED.DLL can also use the following file names:

    * A0046354.DLL
    * A0177030.DLL
    * A0005619.DLL
Comment 1 chris hofmann 2008-06-24 14:22:43 PDT
looks like a candidate for blocking/sumo doc
Comment 2 chris hofmann 2008-06-24 14:36:15 PDT
I left a ticket at http://www.crawler.com/Support.aspx in hopes of getting a contact or response.

Question: xshared.dll 1.0.0.42 in crawler addon not compatible with Firefox 3.0
6/24/2008 1:34:51 PM
Name: Chris Hofmann
Email: <chofmann@mozilla.org>

Subject: xshared.dll 1.0.0.42 in crawler addon not compatible with Firefox 3.0
Question Description:

There are more details in our bug report
https://bugzilla.mozilla.org/show_bug.cgi?id=441649 please
provide comment there on possible diagnosis or a fix, or
contact me as soon as possible.

Comment 3 David Tenser [:djst] 2008-06-24 15:15:45 PDT
Really interesting. Are all those comments coming from the crash report data? ("STOP THIS MADNESS!" etc)

So the solution is to start Firefox in safe mode and uninstall the extension?
Comment 4 chris hofmann 2008-06-24 15:17:43 PDT
yes, that is the theory to be tested..
Comment 5 Ted Mielczarek [:ted.mielczarek] 2008-06-24 18:09:14 PDT
I did see one comment in a crash report indicating that the user knew it was from this extension, but most of them are the usual "why is my firefox crashing?"
Comment 6 Mike Beltzner [:beltzner, not reading bugmail] 2008-06-24 23:01:09 PDT
Dupe of bug 441276?
Comment 7 Mike Beltzner [:beltzner, not reading bugmail] 2008-06-24 23:06:51 PDT
--> addons.mozilla.org::Blocklisting

This continues to be our #1 crash on Windows.
Comment 8 Justin Scott [:fligtar] 2008-06-25 00:24:13 PDT
SQL to blocklist verison 1.2 in Firefox 3:

INSERT INTO blitems (guid, min, max, created, modified) VALUES('{4B3803EA-5230-4DC3-A7FC-33638F3D3542}', '1.2', '1.2', NOW(), NOW());

INSERT INTO blapps (blitem_id, guid, min, max, created, modified) VALUES((SELECT id FROM blitems WHERE guid='{4B3803EA-5230-4DC3-A7FC-33638F3D3542}'), '{ec8030f7-c20a-464f-9b0e-13a3a9e97384}', '3.0a1', '*', NOW(), NOW());

Installed the add-on in Windows and reproduced Firefox crashing on startup every time. Crashing did not occur after the add-on was blocklisted. I only blocked version 1.2 because I didn't see any other version numbers around on the site. 
Comment 9 Justin Scott [:fligtar] 2008-06-25 00:29:32 PDT
Created attachment 326637 [details]
blocklist xml after SQL applied
Comment 10 Justin Scott [:fligtar] 2008-06-25 00:42:44 PDT
Created attachment 326639 [details] [diff] [review]
mozilla.com blocklist patch
Comment 11 Ted Mielczarek [:ted.mielczarek] 2008-06-25 04:58:25 PDT
*** Bug 441276 has been marked as a duplicate of this bug. ***
Comment 12 Ted Mielczarek [:ted.mielczarek] 2008-06-27 05:12:32 PDT
actually this looks like the #1 and #2 topcrash, somehow some of the crash reports don't have symbols, but looking at them they have the same stack.
Comment 13 Ted Mielczarek [:ted.mielczarek] 2008-06-27 05:22:00 PDT
I filed bug 442234 about some of those reports not having symbols.
Comment 14 Samuel Sidler (old account; do not CC) 2008-07-07 20:08:46 PDT
morgamic, can we get this reviewed so we can blocklist this add-on?
Comment 15 Michael Morgan [:morgamic] 2008-07-07 22:15:53 PDT
Comment on attachment 326639 [details] [diff] [review]
mozilla.com blocklist patch

I can add this to the blocklist info page after the SQL is run.
Comment 16 Justin Scott [:fligtar] 2008-07-08 09:29:01 PDT
Filed bug 444124 to run the blocklist SQL.
Comment 17 Justin Scott [:fligtar] 2008-07-08 10:43:45 PDT
Checked in mozilla.com update in r16798. morgamic, can you push live?
Comment 18 Justin Scott [:fligtar] 2008-07-08 13:52:30 PDT
mozilla.com update was pushed live.
Comment 19 chris hofmann 2008-09-09 17:16:53 PDT
looks like it did the trick...  no longer in the top 100 looking at latest 3.0.1 top crashes.
Comment 20 Rowdy 2009-05-03 12:30:53 PDT
Created attachment 375533 [details]
 Bug 441649 -  Firefox 3.0 Crash Report [@ nsBaseWidget::RemoveChild(nsIWidget*) ] - metasearch addon
Comment 21 Dave Miller [:justdave] (justdave@bugzilla.org) 2009-05-03 14:40:29 PDT
The content of attachment 375533 [details] has been deleted by
    Dave Miller [:justdave] <justdave@mozilla.com>
who provided the following reason:

Windows EXE file, unrelated to bug

The token used to delete this attachment was generated at 2009-05-03 14:40:24 PDT.

Note You need to log in before you can comment on or make changes to this bug.