Printing to Adobe Acrobat PDFWriter results in garbage in .PDF file

RESOLVED DUPLICATE of bug 422253

Status

()

RESOLVED DUPLICATE of bug 422253
11 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Printing to the PDFWriter results in bad text.

Characters in the output .PDF file are wrong and look like "orderly garbage".

The spacing and position of text looks correct, but the characters are different than the ones in the print preview field.

It doesn't seem to matter what web page I try to print. It always has the garbage characters in the .pdf file afterward.

Reproducible: Always

Steps to Reproduce:
1. Choose a web site page. Any page should reproduce the problem.
2. Choose File|Print|Preview. Notice that the page looks correct in print-preview.
3. Press the PRINT button and choose Adobe PDFWriter as the output print device.

Actual Results:  
After printing is complete, Acrobat automatically opens the output file. Notice the bad characters in the new file.

Expected Results:  
I expected the text in the PDF file to look the same as the print preview output and the physical print output if printed directly to the printer device.

I have used Acrobat PDFWriter for years to save snapshots of web pages I visited. One major use of this is to save output from a web page that I need to save, such as a bank account page or anything I want to view later.

For some reason, after installing Firefox 3 beta, now this no longer works. Firefox 2 works correctly with PDFWriter, but Firefox 3 produces garbage.

Why this problem is only related to printing in PDFWriter and not physical printing is a mystery to me. Perhaps there's some sort of font issue where Acrobat cannot interpret the font correctly from the browser.

I'm not able to save print output to a file any more and there doesn't appear to be a workaround.
(Reporter)

Comment 1

11 years ago
Created attachment 326620 [details]
PDF Output resulting from this problem

This is from using Acrobat 4.0. I realize this is pretty old, but it used to work with Firefox 2 and now it fails with 3-beta.
(Reporter)

Comment 2

11 years ago
Created attachment 326621 [details]
This is a screenshot of the actual page in the browser and what it should look like in the printout.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422253

Comment 4

10 years ago
This same thing happens to me
You need to log in before you can comment on or make changes to this bug.