Copy sends only plain text to clipboard

RESOLVED DUPLICATE of bug 356218

Status

()

Firefox
Shell Integration
--
major
RESOLVED DUPLICATE of bug 356218
10 years ago
10 years ago

People

(Reporter: Ilyse Kazar, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

NOTE: I am on Mac but chose "All" platforms because I have seen similar complaints coming from Windows users on the forums.

Using Thunderbird 2 as an example target application for a Paste operation, when pasting in text, tables, images, etc. that was copied from a FF3 page only plain text is pasted. When copying from FF2 and then pasting, the html code is retained (in an app like Tbird that grabs the html version off the clipboard) and images are embedded in the Tbird mail body. 

Leads one to think the Copy operation is no longer sending html as well as plain text to the clipboard. IMO this is an undesired change in behavior.

Reproducible: Always

Steps to Reproduce:
1. Select All on a web  page using FF 3.
2. Paste into the body of a new email message in Thunderbird (for example -- I've seen forum posts complaining about the same problem with apps other than Thunderbird, such as Corel Draw).

Actual Results:  
Only plain text is pasted into the document in the external app (Thunderbird in my example)

Expected Results:  
I would expect the results to be the same as with prior versions of FF: For target apps that will choose formatted (html or rtf or whatever) text off the clipboard if it is there, Firefox should be providing the formatted version to the clipboard.

This is a change in behavior from FF 2 (and I believe even 1). I'm hoping it qualifies as a bug and was not intentional!! I literally need to close FF3 and open the page in FF2 in order to copy/paste the way I used to, then go back to FF3 because in all other ways it is SO superior and I love it. please fix!!!
(Reporter)

Comment 1

10 years ago
(In reply to comment #0)


> Steps to Reproduce:
> 1. Select All on a web  page using FF 3.

Sorry!! The above should be:

SelectAll on a web page using FF 3 **and Copy**.

> 2. Paste into the body of a new email message in Thunderbird (for example --
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Updated

10 years ago
OS: Mac OS X → All

Comment 2

10 years ago
Works for me using MS Word/Pidgin and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Just to check in Thunderbird are you composing a plain text email message? 
(Reporter)

Comment 3

10 years ago
No, an html message. I just fired up my old XP and I agree w/you that this bug does not exhibit on Windows. But I have confirmed this bug on Mac, have tested on all 3 of our macs (all PPC's running 10.4.11).

Changing the hardware & platform accordingly to Mac, but perhaps someone on Linux should also test (I am not lucky enuf to have linux running here)
OS: All → Mac OS X
Hardware: All → Macintosh
(Reporter)

Comment 4

10 years ago
I should add that there are copy/paste formatting issues being reported all over the forums WRT FF3. Just in case there is any correlation between this Mac-only (or Mac&nix) bug and other problems folks are seeing with clipboard integration.

Some examples are in this thread, all of them appear to be by Windows users: http://tinyurl.com/5d472t
 (you can preview that redirect at: http://preview.tinyurl.com/5d472t)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356218
You need to log in before you can comment on or make changes to this bug.