No option to suppress Domain Mismatch dialog

RESOLVED DUPLICATE of bug 228684

Status

RESOLVED DUPLICATE of bug 228684
11 years ago
11 years ago

People

(Reporter: scunliffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: version 2.0.0.14 (20080421)

The Domain Mismatch dialog in Thunderbird is good, however there are times when a certificate mismatch is "OK" to the end user.  However the dialog constantly re-appears if you have the error, with no option to suppress it.  Thus every time you check for mail or "focus/touch" that mail account, you will get the error.

(Dialog error, modified with suggestion note added as attachment)

Reproducible: Always

Steps to Reproduce:
1. Setup a mail account (IMAP?) with a domain certificate that doesn't quite match the mail domain you are accessing.
2. Retrieve mail
3. Note dialog.  Note there is no way to dismiss it permanently (or even for "this" session)
Actual Results:  
no way to dismiss dialog permanently (or even for "this" session)

Expected Results:  
some way to dismiss dialog permanently (or even for "this" session)
(Reporter)

Comment 1

11 years ago
Created attachment 327109 [details]
Domain Mismatch Dialog, modified with notes for suggested improvement
(Reporter)

Comment 2

11 years ago
I should note that in the attached dialog image, I have replaced the domain in question, however the domain I'm accessing, is definately a "subdomain" of the larger "mail.myServer.myCompany.ca" domain.

E.g. I totally trust the domain certificate, even though the match isn't === 100% match
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 228684
You need to log in before you can comment on or make changes to this bug.