[D&D] Dragging image across browser windows ---> error

RESOLVED WORKSFORME

Status

()

Core
XUL
P4
normal
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Eli Goldberg, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][p:4][minus])

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Dragging image across browser windows ---> error dialog

* STEPS TO REPRODUCE
0) Launch Seamonkey
1) Execute test case at
http://www.mozilla.org/quality/browser/front-end/testcases/drag-drop/drag-img-browser-browser/drag-img-browser-browser-d.html

* RESULT
 - What happened

An error message of, "www.shuttle_small.jpg could not be found. Please check the
name and try again" results.

 - What was expected

Either the image should be successfully dragged, or a more meaningful error
message should be provided to the user.


* REGRESSION

 - Occurs On
        Mac OS & Win32 Seamonkey (6.29.00 Mozilla build)		
		(Not tested on Linux, as today's build is busted. Will try yesterday's...)
		

* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Reporter)

Comment 1

18 years ago
[Drag & Drop bug --- QA assigning to self.]
OS: Mac System 8.5 → All
QA Contact: jrgm → elig
(Reporter)

Updated

18 years ago
OS: All → Mac System 8.5
(Reporter)

Comment 2

18 years ago
[fixing changes using a non-Seamonkey build, as today's Moz build is messing up 
the form content.]

Since I can't get any Mozilla build on Linux from the past 3 days to display 
pages, Linux testing is omitted pending receipt of a functional build.
OS: Mac System 8.5 → All

Comment 3

18 years ago
Eli -- have you been able to test this on Linux yet?
(Reporter)

Comment 4

18 years ago
Hadn't tried. On Linux using this morning's build, the drag operation does 
nothing.

Comment 5

18 years ago
I see a problem with my Macintosh debug build from today.  I will investigate 
this once we are past nsbeta2.
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 6

18 years ago
this may be related to 41901, but will not mark as a dup
Keywords: correctness, nsbeta3

Comment 7

18 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=45828

That I filed last night seems to be closely related.
The description doesn't make it an exact duplicate but I think its the same 
underyling bug.

Comment 8

18 years ago
*** Bug 45828 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
this appears to be a problem with a relative uri (as opposed to an absolute uri).  
I believe links and images have this problem.

Comment 10

18 years ago
the issue here is that dragging of images (and links) only work if they are 
absolute, relative urls cause the error to occur, bith url types must work -- 
setting to nsbeta3+
Whiteboard: nsbeta3+

Updated

18 years ago
Summary: Dragging image across browser windows ---> error → [D&D] Dragging image across browser windows ---> error

Updated

18 years ago
Whiteboard: nsbeta3+ → [nsbeta3+]

Comment 11

18 years ago
adding priority to status whiteboard, not really high risk and not *too* 
complicated but time-consuming
Priority: P3 → P4
Whiteboard: [nsbeta3+] → [nsbeta3+][p:4]

Comment 12

18 years ago
reassign to Ben since this fix will be in navigatorDD.js file; Ben, I'm going on 
sabbatical so I won't be able to fix this for 6 weeks.  Sorry!
Assignee: brade → ben
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Priority: P4 → P3

Updated

18 years ago
Priority: P3 → P4

Comment 13

18 years ago
PDT is downgrading this P4 bug to [nsbeta3-].
Whiteboard: [nsbeta3+][p:4] → [nsbeta3-][p:4][minus]

Comment 14

18 years ago
*** Bug 55956 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
*** Bug 55958 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: elig → jrgm

Updated

17 years ago
Target Milestone: M18 → ---
Target Milestone: --- → Future

Comment 16

16 years ago
removing myself from the cc list
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Status: ASSIGNED → NEW

Comment 18

14 years ago
While tring to track down dupes of another bug I came across this bug. 

However this bug WFM in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9 and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a) Gecko/20040517

I was able to drag the google.gif from one window to another with out any problems.
Assignee: ben_seamonkey → jag
QA Contact: jrgmorrison → xptoolkit.widgets

Updated

9 years ago
Assignee: jag → nobody

Comment 19

9 years ago
=> WFM based on comment 18
(testcase URL has moved)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.