New mail tray notifyer triggered even if a filter applys with "mark as read"

RESOLVED DUPLICATE of bug 379363

Status

RESOLVED DUPLICATE of bug 379363
10 years ago
10 years ago

People

(Reporter: jpstotz, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.50 (Windows NT 5.1; U; de)
Build Identifier: 2.0.0.14

For some high traffic mailing list I have set up filters that automatically move the mails in a special sub-folder on my IMAP account and mark them read.
Now if new mail from such list arrives I get a new mail notification (sound and try icon appears, but the try-summary pop-up does not show up). 
Double clicking on tray icon does open thunderbird, but does not select the correct IMAP account nor the correct folder. 
As the affected mailing are high traffic, this "false new mail notification" happens very often which is very annoying.

Reproducible: Sometimes

Steps to Reproduce:
1. Create a sub-folder "XYZ" for the mails to be received on an IMAP account
2. Add a filter that applies to certain messages. The filter contains two commands: (1) move mail to folder "XYZ"; (2) mark mail as read
3. Send yourself mails that trigger the filter
Actual Results:  
Often the new mail notification sound is played and the tray icon notifier appears.

Expected Results:  
Thunderbird should be silent.

Capability listing of used IMAP server:
IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ MAILBOX-REFERRALS NAMESPACE UIDPLUS ID NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND BINARY SORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE IDLE AUTH=LOGIN AUTH=PLAIN SASL-IR LISTEXT LIST-SUBSCRIBED X-NETSCAPE
(Reporter)

Comment 1

10 years ago
Forget to specify the TB version
Version: unspecified → 2.0
379363 seems to describe nearly the exact same things, but I swear that itself is a dupe of another bug. Oh well, in the meantime:
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379363
You need to log in before you can comment on or make changes to this bug.