Last Comment Bug 442736 - If browser.startup.page is equal to 3, browser.warnOnQuit should be changed to false
: If browser.startup.page is equal to 3, browser.warnOnQuit should be changed t...
Status: RESOLVED FIXED
: polish
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: 3.6 Branch
: All All
: -- minor with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 419009 428742
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 12:48 PDT by Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m)
Modified: 2012-03-01 02:56 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.93 KB, patch)
2010-07-06 18:04 PDT, Michael Kohler [:mkohler]
dao+bmo: review-
Details | Diff | Splinter Review

Description Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-30 12:48:38 PDT
After you enable the the preference "Show my windows and tabs from last time" - browser.startup.page=3 - browser.warnOnQuit should be changed to false to avoid any user misunderstanding, even if the preference is ignored in this case. This should be done also at Fx startup.
Comment 1 Michael Kohler [:mkohler] 2010-07-05 12:33:51 PDT
Is this still wanted?
Comment 2 Michael Kohler [:mkohler] 2010-07-06 18:04:36 PDT
Created attachment 456214 [details] [diff] [review]
Patch v1

Frankly, I'm not quite sure if this is the right place to do this, but at least it works.
Comment 3 Dão Gottwald [:dao] 2010-07-08 12:04:41 PDT
I don't think this makes much sense. What would make sense is to make it easier to understand what the pref means by renaming it e.g. to browser.warnOnQuitIfTabsWontBeRestored, but that's probably not worth it...
Comment 4 Dão Gottwald [:dao] 2010-07-08 12:07:35 PDT
Comment on attachment 456214 [details] [diff] [review]
Patch v1

Also, even if we would want this, letting every window observe the pref like this wouldn't be the right way to do it.
Comment 5 eyal gruss (eyaler) 2011-01-21 12:20:21 PST
invalid due to Bug 592822?
Comment 6 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2011-02-09 09:26:05 PST
(In reply to comment #3)
Well, I must agree with you. You can WONTFIX.
Comment 7 Phoenix 2012-03-01 02:56:26 PST
Wanted behavior was achieved with Bug 629485

Note You need to log in before you can comment on or make changes to this bug.