Closed Bug 442949 Opened 12 years ago Closed 12 years ago

June 17th Windows Ts regression from SQLite upgrade

Categories

(Toolkit :: Storage, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: sayrer, Assigned: sdwilsh)

References

Details

Windows XP machines (qm-pxp-trunk01 etc.) show a regression from 1017ms -> 1043ms.
Assignee: nobody → sdwilsh
Is it just windows XP, or does vista show it as well?

The fast mac talos showed a small bump, and alice rebooted the machines and it went away.  Perhaps the same needs to be done here?

Also, this landed in CVS too - anything show up there?  If I could get the graph server to load without crashing I could answer these myself...
Blocks: 435414
GranParadiso works still :)

Looks to be Vista too on central, but only windows picks this up:
XP: http://tinyurl.com/5os2cr
Vista: http://tinyurl.com/67suj8
Mac: http://tinyurl.com/6roh9f
Leopard: http://tinyurl.com/5mdrfg
Linux: http://tinyurl.com/68kzxe

Whereas, on cvs trunk only XP sees a jump on the 24th, which correlates to sqlite landing in cvs
XP: http://tinyurl.com/3nhuj6
Vista: http://tinyurl.com/4dxmqy
Mac: http://tinyurl.com/4kwooq
Linux: http://tinyurl.com/492ovs

The fact that vista is different on cvs and on central, I'd like to see the machines rebooted to see if it helps.
Just to be clear, I'd like to see qm-mini-xp01, qm-mini-xp02, qm-mini-xp03, qm-pxp-trunk01, qm-pxp-trunk02, qm-pxp-trunk03, qm-pvista-trunk01, qm-pvista-trunk02, and qm-pvista-trunk03 rebooted.
Is the severity for this bug correctly set at 'normal'?  What sort of timeline/priority do you want the machine reboots to be on?
(In reply to comment #4)
> Is the severity for this bug correctly set at 'normal'?  What sort of
> timeline/priority do you want the machine reboots to be on?
I'm going to leave this up to the drivers.
(In reply to comment #4)
> Is the severity for this bug correctly set at 'normal'?  What sort of
> timeline/priority do you want the machine reboots to be on?
Let's get this done ASAP please.

drh:
Did anything major change in sqlite between 3.5.4.2 and 3.5.9 for windows specific code for opening a database?  It appears as though we are seeing an increase in the time it takes for application startup, and we have a number of databases that are opened during this time.  This increase did not appear on OS X or Linux, however.
Severity: normal → critical
According to drh, these are the only changes to windows code between our old version and the new version:
http://www.sqlite.org/cvstrac/chngview?cn=4802
http://www.sqlite.org/cvstrac/filediff?f=sqlite/src/os_win.c&v1=1.120&v2=1.121
The one change is entirely inside an ifdef for WINCE, so we don't get that, and the other is changing the name of a function.  I'd really like to get those machines rebooted because the jump doesn't make sense from a code-change perspective.
Depends on: 443301
So, I've let the rebooting sit for about two days, and here are the results:

CVS:
One winxp machine is still high, one dropped to, or close to previous levels, and the third is just above that.  The two machines that are at or near previous levels appear to be a bit more noisy now though.  Hurray for machines not agreeing at all...
The vista machines actually seem to be on a slow, but steady climb over the past 30 days, but no change with sqlite landing (these were not rebooted, but maybe they should because of that steady increase).

mozilla-central:
We appear to have lost qm-pxp-trunk01 after the reboot, but xp shows no change - still seeing a regression here.
For vista, we had a drop, but it's climbing back up.  Looks like we had a small climb going on before sqlite landed, but I don't think it dropped to the point where it would have been before.  Regardless, I don't think it dropped back where it would have gone without sqlite being in there.

I guess our next step here is to backout the sqlite upgrade.
backed it out
note: didn't back out of CVS since that tree has all sorts of orange still
OS: Mac OS X → All
Hardware: PC → All
Version: unspecified → Trunk
(In reply to comment #9)
> backed it out

Did it help?
(In reply to comment #11)
> Did it help?
I'm waiting for at least a few cycles of talos before I answer to make sure numbers are stable.
All the windows machines on central did drop back down to (or below) their previous levels with this backout.  I'm guessing this is fixed?
Marking this as fixed since the regression has gone away.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to comment #10)
> note: didn't back out of CVS since that tree has all sorts of orange still
> 
Was this ever backed out of FF3.0 (on cvs)?
(In reply to comment #15)
> Was this ever backed out of FF3.0 (on cvs)?

No, see bug 435414 comment 18.
You need to log in before you can comment on or make changes to this bug.