scrollboxes scroll to offset 0 when resized

RESOLVED DUPLICATE of bug 170045

Status

()

RESOLVED DUPLICATE of bug 170045
11 years ago
10 years ago

People

(Reporter: mnemo, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: 

1. install thunderbird on ubuntu (I used 2.0.0.14 for this repro)
2. create a large set of local folders so that you have about two screenfulls of local folders
3. select the top "inbox" node
4. scroll the list of local folders to the bottom
5. resize the local folders panel to be a little bit bigger

Expected:
I just want to resize it, I don't want it to change the scroller position as a side effect,

Actual:
The scrollbox/panel that contains the local folder will automatic scroll to offset 0 making the selected "inbox" item visible again.

Note: I think this is a bug in the mozilla platform or whatever because I see the same buggy effect when I create a large amount of filter rules inside the "Tools::Message Filters" dialog (to repro the bug in there I just create two screenfulls of filter rules (about 60 or so) and then select the first rule, scroll to the bottom and then resize the entire "Message Filters" dialog window.

Originally reported to the Ubuntu project here:
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/244635


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This is an XUL problem.
Status: UNCONFIRMED → NEW
Component: General → XP Toolkit/Widgets: XUL
Ever confirmed: true
Product: Thunderbird → Core
QA Contact: general → xptoolkit.xul
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

11 years ago
The list view used Edit::Preferences::Advanced::Encryption::View Certificates::Authorities for Firefox 2.0.0.15 on Ubuntu exhibits the same problem, so it's definitely a platform problem. This problem has been fixed in FF3 though so compiling against the mozilla trunk XULRunner will likely be sufficient to fix this bug (this is itself of course not exactly a trivial thing to do I suppose).

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 170045
(Reporter)

Comment 4

11 years ago
I know this is fixed in Core, but does that also been it will be fixed in thunderbird? If so, in what release? This bug is still annoying me daily :-)

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.