Closed Bug 444013 Opened 12 years ago Closed 12 years ago

Centralize win32 theme implementation

Categories

(Core :: Widget: Win32, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.1a1

People

(Reporter: robarnold, Assigned: robarnold)

References

Details

Attachments

(1 file, 2 obsolete files)

Currently there is duplicated code in nsNativeThemeWin and nsLookAndFeel which should be consolidated into one location.
Summary: Centralize win32 theme implemenation → Centralize win32 theme implementation
Attached patch nsNativeThemeData v1.0 (obsolete) — Splinter Review
Creates a nsNativeThemeData class which is initialized once for the entire application.
Assignee: nobody → tellrob
Status: NEW → ASSIGNED
Attachment #329127 - Flags: review?(vladimir)
Attached patch nsUXThemeData v1.1 (obsolete) — Splinter Review
As discussed over IRC, renamed nsNativeThemeData to nsUXThemeData and made all the members static. Also fixed a bug where the text colors for Media and Communications toolbars was incorrect.
Attachment #329127 - Attachment is obsolete: true
Attachment #329145 - Flags: review?(vladimir)
Attachment #329127 - Flags: review?(vladimir)
I'd also move mFlatMenus and the detection of the Windows version to nsNativeThemeData since those are also duplicated.
Moved version checks and flat menu detection into nsUXThemeData. Also renamed nsNativeThemeConstants.h to nsUXThemeConstants.h
Attachment #329145 - Attachment is obsolete: true
Attachment #329151 - Flags: review?(vladimir)
Attachment #329145 - Flags: review?(vladimir)
Pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/index.cgi/rev/68ddc8f23721
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1a1
Depends on: 446286
Depends on: 448104
Blocks: 386929
The checkin for this bug caused a regression where Firefox crashes on shutdown, see bug 448104.
You need to log in before you can comment on or make changes to this bug.