Last Comment Bug 444200 - When Adobe Flash Player 10 Beta 2 is enabled, Firefox experiences random crashes, especially on sites containing flash or flash video and sometimes accompanied by corruption of said flash video before the crash.
: When Adobe Flash Player 10 Beta 2 is enabled, Firefox experiences random cras...
Status: RESOLVED FIXED
[FP 10.1.53.64]
: crash
Product: External Software Affecting Firefox
Classification: Components
Component: Flash (Adobe) (show other bugs)
: unspecified
: x86 Linux
: -- critical with 2 votes (vote)
: ---
Assigned To: Jet Villegas (:jet)
:
:
Mentors:
http://www.delta.com.tw/product/cp/dc...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-08 14:22 PDT by Jonathan Busby
Modified: 2016-04-28 10:07 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Copy of Crash Reports directory (47.05 KB, application/x-bzip)
2008-07-08 16:42 PDT, Jonathan Busby
no flags Details
copy of minidumps directory (53.93 KB, application/x-bzip)
2008-07-08 16:43 PDT, Jonathan Busby
no flags Details

Description Jonathan Busby 2008-07-08 14:22:41 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

I recently installed the latest version of Firefox 3. I then installed Adobe Flash Player 10 Beta 2. It should be noted that Adobe updated the player -- from labs.adobe.com :

"Update: Flash Player 10 beta 2 was released on 7/2/2008 and includes new features and bug fixes. The Mac build was refreshed on 7/7/2008. Please download the new version."

Immediately after restarting Firefox and navigating to the YouTube home page I experienced a lock-up in addition to the Flash video windows being garbled -- like a television tuned to a non-existent channel, but with color. Performing the same actions as just previously described then produced sporadic lock-ups, segfault, and crashes. Also, when navigating a web page that contains no Flash content, Firefox experienced random, sporadic segfaults, lock-ups, and crashes. 

**When the Adobe Flash Player 10 Beta 2 Plugin is *disabled* using the Extension manager, all of the above problems cease.**

I was, until I installed the latest version Firefox 3, using a previous version of the player, with a possibly previous version of Firefox 3. I did not experience *any* problems with that configuration. So, I'm really not sure if this behavior is the result of Firefox or Adobe Flash Player 10 Beta 2.

Reproducible: Sometimes

Steps to Reproduce:
1. Install or enable Adobe Flash Player 10 Beta 2
2. Navigate to http://www.delta.com.tw/
3. Move the mouse cursor over the "Products" link. A drop down menu should appear.
4. Move the mouse cursor to the "Components" entry. Another drop down menu should appear
5. Select "DC Brushless Fans & Blowers"
6. Firefox should segfault, crash, or lock up.
Actual Results:  
Firefox segfaulted

Expected Results:  
Taken me to the selected web page.

Operating System: Linux Knoppix 2.6.24.4 #2 SMP PREEMPT Tue Mar 25 21:35:28 CET 2008 i686 GNU/Linux ( obtained using uname -a )
Comment 1 Matthias Versen [:Matti] 2008-07-08 16:01:45 PDT
Please either provide crash IDs or stack traces or just install Flash9 r124.
If you don't crash with Flash9r124 report the problems to adobe.
Comment 2 Jonathan Busby 2008-07-08 16:42:32 PDT
Created attachment 328591 [details]
Copy of Crash Reports directory
Comment 3 Jonathan Busby 2008-07-08 16:43:07 PDT
Created attachment 328592 [details]
copy of minidumps directory
Comment 4 Jonathan Busby 2008-07-08 16:43:38 PDT
(In reply to comment #1)
> Please either provide crash IDs or stack traces or just install Flash9 r124.
> If you don't crash with Flash9r124 report the problems to adobe.
> 

I've attached the crash dumps.
Comment 5 Matthias Versen [:Matti] 2008-07-08 16:57:37 PDT
We can not use the minidumps because only the server has the symbols.
We need just the IDs and we can look at the stack if the server processed your dump.
The crash reporter couldn't send your report because of this error :
[Tue Jul  8 13:51:35 2008] Crash report submission failed: Problem with the SSL CA cert (path? access rights?)

You need to install some CA certificates...
Comment 6 Jonathan Busby 2008-07-08 17:37:22 PDT
(In reply to comment #5)
> We can not use the minidumps because only the server has the symbols.
> We need just the IDs and we can look at the stack if the server processed your
> dump.
> The crash reporter couldn't send your report because of this error :
> [Tue Jul  8 13:51:35 2008] Crash report submission failed: Problem with the SSL
> CA cert (path? access rights?)
> 
> You need to install some CA certificates...
> 

Can you be more specific? 
Comment 7 Matthias Versen [:Matti] 2008-07-08 18:16:36 PDT
read for example bug 407748 (ubuntu)
Comment 8 Jonathan Busby 2008-07-08 18:50:37 PDT
(In reply to comment #7)
> read for example bug 407748 (ubuntu)
> 

Thanks for the tip. Installed the ca-certificates package and I was able to generate a segfault and have the bug report sent to the server.
Comment 9 Matthias Versen [:Matti] 2008-07-09 07:18:04 PDT
Great, now enter about:crashes as URL in Firefox and provide the crash ID.
Comment 10 Jonathan Busby 2008-07-09 08:42:46 PDT
(In reply to comment #9)
> Great, now enter about:crashes as URL in Firefox and provide the crash ID.
> 

Here's the crash ID : f1e1bbe6-4d58-11dd-9796-001a4bd43ed6
Comment 11 Matthias Versen [:Matti] 2008-07-12 23:50:49 PDT
Are you sure that you had the same crash because this is a Gecko crash and not a Flash crash :
0  	libxul.so  	imgContainer::ResetDiscardTimer  	 mozilla/modules/libpr0n/src/imgContainer.cpp:1252
1 	libxul.so 	imgContainer::RestoreDiscardedData 	mozilla/modules/libpr0n/src/imgContainer.cpp:1281
2 	libxul.so 	imgContainer::GetCurrentFrameNoRef 	mozilla/modules/libpr0n/src/imgContainer.cpp:168
3 	libxul.so 	imgContainer::GetCurrentFrame 	mozilla/modules/libpr0n/src/imgContainer.cpp:184
4 	libxul.so 	imgRequest::NotifyProxyListener 	mozilla/modules/libpr0n/src/imgRequest.cpp:219
5 	libxul.so 	imgRequestProxy::Clone 	mozilla/modules/libpr0n/src/imgRequestProxy.cpp:349
6 	libxul.so 	nsImageBoxFrame::UpdateImage 	mozilla/layout/xul/base/src/nsImageBoxFrame.cpp:283
7 	libxul.so 	nsImageBoxFrame::DidSetStyleContext 	mozilla/layout/xul/base/src/nsImageBoxFrame.cpp:420
8 	libxul.so 	nsIFrame::SetStyleContext 	mozilla/layout/generic/nsIFrame.h:613

Do you have another crash ID to be sure ?
Comment 12 Jonathan Busby 2008-07-14 18:27:00 PDT
(In reply to comment #11)
> Are you sure that you had the same crash because this is a Gecko crash and not
> a Flash crash :
> 0       libxul.so       imgContainer::ResetDiscardTimer         
> mozilla/modules/libpr0n/src/imgContainer.cpp:1252
> 1       libxul.so       imgContainer::RestoreDiscardedData     
> mozilla/modules/libpr0n/src/imgContainer.cpp:1281
> 2       libxul.so       imgContainer::GetCurrentFrameNoRef     
> mozilla/modules/libpr0n/src/imgContainer.cpp:168
> 3       libxul.so       imgContainer::GetCurrentFrame  
> mozilla/modules/libpr0n/src/imgContainer.cpp:184
> 4       libxul.so       imgRequest::NotifyProxyListener        
> mozilla/modules/libpr0n/src/imgRequest.cpp:219
> 5       libxul.so       imgRequestProxy::Clone 
> mozilla/modules/libpr0n/src/imgRequestProxy.cpp:349
> 6       libxul.so       nsImageBoxFrame::UpdateImage   
> mozilla/layout/xul/base/src/nsImageBoxFrame.cpp:283
> 7       libxul.so       nsImageBoxFrame::DidSetStyleContext    
> mozilla/layout/xul/base/src/nsImageBoxFrame.cpp:420
> 8       libxul.so       nsIFrame::SetStyleContext      
> mozilla/layout/generic/nsIFrame.h:613
> 
> Do you have another crash ID to be sure ?
> 

Here's another crash ID : 4f20a52e-520c-11dd-8af6-001a4bd43ed6
Comment 13 timeless 2008-07-15 06:12:19 PDT
Signature	libflashplayer.so@0xd83da
UUID	4f20a52e-520c-11dd-8af6-001a4bd43ed6
Time	2008-07-14 18:20:03-07:00
Uptime	11
Product	Firefox
Version	3.0
Build ID	2008052912
OS	Linux
OS Version	0.0.0 Linux 2.6.24.4 #2 SMP PREEMPT Tue Mar 25 21:35:28 CET 2008 i686 GNU/Linux
CPU	x86
CPU Info	AuthenticAMD family 1 model 10 stepping 0
Crash Reason	SIGSEGV
Crash Address	0xb06a73da
Comments	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	libflashplayer.so 	libflashplayer.so@0xd83da 	
1 	libflashplayer.so 	libflashplayer.so@0xccd89 	
2 	libflashplayer.so 	libflashplayer.so@0xc3d7f 	
3 	libflashplayer.so 	libflashplayer.so@0xc88b3 	
4 	libxul.so 	ns4xPluginInstance::HandleEvent 	mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp:1310
5 	libxul.so 	nsPluginInstanceOwner::Renderer::NativeDraw 	mozilla/layout/generic/nsObjectFrame.cpp:4155
6 	libxul.so 	NativeRendering 	mozilla/gfx/thebes/src/gfxXlibNativeRenderer.cpp:59
7 	libxul.so 	cairo_draw_with_xlib 	mozilla/gfx/thebes/src/cairo-xlib-utils.c:312
8 	libxul.so 	gfxXlibNativeRenderer::Draw 	mozilla/gfx/thebes/src/gfxXlibNativeRenderer.cpp:101
9 	libxul.so 	nsPluginInstanceOwner::Paint 	mozilla/layout/generic/nsObjectFrame.cpp:4076
10 	libxul.so 	nsObjectFrame::PaintPlugin 	mozilla/layout/generic/nsObjectFrame.cpp:1400
11 	libxul.so 	PaintPlugin 	mozilla/layout/generic/nsObjectFrame.cpp:1096
12 	libxul.so 	nsDisplayGeneric::Paint 	mozilla/layout/base/nsDisplayList.h:862
13 	libxul.so 	nsDisplayList::Paint const 	mozilla/layout/base/nsDisplayList.cpp:296
14 	libxul.so 	nsDisplayClip::Paint 	mozilla/layout/base/nsDisplayList.cpp:693
15 	libxul.so 	nsDisplayList::Paint const 	mozilla/layout/base/nsDisplayList.cpp:296
16 	libxul.so 	nsLayoutUtils::PaintFrame 	mozilla/layout/base/nsLayoutUtils.cpp:988
17 	libxul.so 	PresShell::Paint 	mozilla/layout/base/nsPresShell.cpp:5413
18 	libxul.so 	nsViewManager::RenderViews 	mozilla/view/src/nsViewManager.cpp:614
19 	libxul.so 	nsViewManager::Refresh 	mozilla/view/src/nsViewManager.cpp:502
20 	libxul.so 	nsViewManager::DispatchEvent 	mozilla/view/src/nsViewManager.cpp:1134
21 	libxul.so 	HandleEvent 	mozilla/view/src/nsView.cpp:168
22 	libxul.so 	nsCommonWidget::DispatchEvent 	mozilla/widget/src/gtk2/nsCommonWidget.cpp:158
23 	libxul.so 	nsWindow::OnExposeEvent 	mozilla/widget/src/gtk2/nsWindow.cpp:1763
24 	libxul.so 	expose_event_cb 	mozilla/widget/src/gtk2/nsWindow.cpp:4529
Comment 14 Mardeg 2008-08-17 12:09:05 PDT
Reporter, can you let us know if this still happens with the Flash 10 Release Candidate? http://labs.adobe.com/downloads/flashplayer10.html
Comment 15 Jonathan Busby 2008-08-18 11:48:43 PDT
(In reply to comment #14)
> Reporter, can you let us know if this still happens with the Flash 10 Release
> Candidate? http://labs.adobe.com/downloads/flashplayer10.html
> 

The stability problems seem to be gone, but unfortunately other issues appear to have arisen. For example, when I try to view a video on Youtube in "High Quality" mode I get the error : "We're sorry, this video is no longer available". Similarly, when I try to watch a video on Youtube using the H.264 codec by appending '&fmt=18' to the URL I get the same error. Both of the previous problems do not exist, at least from my experience, in Flash Player 9.

Another problem that I've noticed is that most videos that are not hosted by Google will not play via video.google.com with Flash Player 10 installed -- all I get is a black rectangle where the video should be. Again, this problem has not manifested itself to me in Flash Player 9.
Comment 16 dick thompson 2008-08-23 10:11:32 PDT
Having the same problem today with the Althouse blog.  Her first posting has a flash video and when you bring up her website directly it crashes Firefox and leaves no error message.  If you bring up her website by bringing up Firefox and then going to her website you can look at one posting and its comments.  When you try to go back to the previous screen (alt-left) it shows initially the flash video block and then crashes, again with no error message.  I got the notice of reporting to Mozilla when it crashed it said there were no error messages and that the messages were saved in a file but when I went to the file it was empty and again there was no error message.  

I tried this on Ubuntu, Kubuntu, Mandriva, Wolvix, Pardus and PCLinuxOS Linux Distributions and got the same result every time.  
Comment 17 Peter Janes 2008-10-15 20:52:29 PDT
I've seen this twice today within hours of installing the final Flash 10 release (the i386 RPM version 10.0.12.36-release, from Adobe's yum server).  Crash IDs are c2b6148a-9b27-11dd-b6c9-001cc45a2ce4 and 14b36ec7-9b27-11dd-8b75-001cc45a2ce4.  Although there's no indication of Flash I can see in the crash reports---they appear to be almost empty, not even having a signature---after removing the plugin the crashes disappear.

I've got both Flashblock and NoScript set to prevent Flash but neither prevents the plugin from crashing the browser.
Comment 18 m 2008-10-21 08:37:25 PDT
since updating my flash to verion 10, I've got the same problem - browser crashes randomly on flash animations... youtube is still perfect example - I can watch 2 or 3 movies, then firefox crashes. it's so annoying especially that a browser is my working environment. I hoped this problem to be solved in 3.0.3, but it hasn't been solved.
Comment 19 Matthias Versen [:Matti] 2008-10-21 09:45:23 PDT
How can you expect a fix in the browser if the flash plugin itself is crashing ?
(comment #13 is a crash of the flash plugin)

If you got this with flash10, why do you don't downgrade and ask Adobe for a fix ?
Comment 20 m 2008-10-21 09:54:27 PDT
(In reply to comment #19)
> How can you expect a fix in the browser if the flash plugin itself is crashing
> ?
> (comment #13 is a crash of the flash plugin)
> 
> If you got this with flash10, why do you don't downgrade and ask Adobe for a
> fix ?

because version 9 used to crash firefox 3 too, firefox 2 was not affected.
also, if I create a new profile, for some time firefox 3 works fine with flash 9/10, then it starts to crash my browser.

if the flash is crashing, why not just unload plugin and reload it and not crashing firefox at the same time? it's not really a user friendly feature - I usually have 3 or 4 windows open with multiple tabs - I need them in my work. sometimes I need or want to check out something - now I have to start opera or konqueror (I don't like both of them) in order to prevent my firefox being crashed... very user friendly :)

sometimes at home I am just browsing a web, without any reason sometimes browser crashes - don't know which fault is that? Firefox 3? Fedora with broken pulseaudio? or Flash?

people are having trouble with flash under linux and I was trying to find any information why it happens - but no one actually is willing to help. If I knew it's a pulse audio, I could try to force Fedora developers to fix it :)
Comment 21 Matthias Versen [:Matti] 2008-10-21 11:07:31 PDT
>if the flash is crashing, why not just unload plugin and reload it and not
>crashing firefox at the same time?

Not possible because plugins are running in the same process and a crashing Thread kills the whole process. We have an open enhancement request bug for out-of-Process plugins, search for it.
You have to see the stacktrace to be sure that you are get the same crash. In comment#18 you statement that you got the same problem with flash10 could be wrong because you can't be sure without looking at a stack trace.
Comment 22 Ming Tang 2008-10-24 11:26:53 PDT
This page will cause more crash:
http://uncyclopedia.org/wiki/YouTube_Poop
because it contained too much videos
Comment 23 Cristian Fernandez 2008-10-26 18:25:43 PDT
Firefox 3.0.2 on Fedora 9 .
Everythig worked in acceptable fasion (Seldom firefox crashes, but acceptable)
Since upgrading to Flash 10, Firefox crashed so much it's unusable.
My solution: Now using Opera. It works with Flash 10, and never crashes. I really hope Firefox will be much more stable in the future, as it's my browser of choice.
Comment 24 aravindm 2010-03-31 23:19:51 PDT
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Reporter, Please update if you are able to still reproduce with the latest nightly build ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Comment 25 Jonathan Busby 2010-04-01 12:15:54 PDT
I've recently built a new system and am now running Kubuntu 64-bit. I have the Ubuntu Mozilla Daily repository as one of my software sources and I receive updates, sometimes multiple, to Firefox 3.6.3pre daily. I also have Adobe's Alpha 64-bit Flash plugin installed.

I do not experience any of the issues described in this report any more, nor have I experienced them for the past year on my previous system.

I think it's safe to say that Adobe fixed the problem, whatever it was.
Comment 26 Jet Villegas (:jet) 2010-06-06 14:48:15 PDT
Marking fixed in FP 10.1.53.64.
Comment 27 BMO Automation 2016-04-28 10:07:52 PDT
Version and milestone values are being reset to defaults as part of product refactoring.

Note You need to log in before you can comment on or make changes to this bug.