Closed Bug 444697 Opened 13 years ago Closed 12 years ago

Error if send while compacting.

Categories

(Thunderbird :: Message Compose Window, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mitra_lists, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: version 3.0a2pre (2008070703)

I use my inbox as my sent folder. 
If the inbox is being compacted when a message is sent, then there is an error
"There was an error copying to your Send folder" 

Unfortunately whatever option is chosen it seems to get stuck in a loop - with occasionally another error asking about whether not to save it. (Sorry I can't copy exact error text).

Reproducible: Sometimes

Steps to Reproduce:
1. Set Sent folder to Inbox
2. Delete a lot of messages in the Inbox
3. Compose a message
4. Wait till Inbox gets compressed (window goes blank during the process)
5. Click Send
6. Keep clicking any dialogue options



Expected Results:  
I would expect it to save the messsage as soon as the compaction completes. OR at worst allow you to continue without saving.

This might sound obscure, but I find it happens often. The typical scenario is reading an inbox with a lot new mail, deleting most, and then replying to a message.

Its quite severe, because at times I've had to Force-Quit Thunderbird to continue.
pretty sure this is a dupe
Severity: normal → major
Whiteboard: dupeme
(In reply to comment #1)
> pretty sure this is a dupe

Could not find it.
Whiteboard: dupeme
Mitra , anything in Tools -> Error Console when this happens ?
I haven't noticed this for a long time, and indexing/compression behavior seems to have been changed in the meantime.
Ok thanks fro replying. -> WFM
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.