If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox upgrades don't check for remote extension compatibility

VERIFIED DUPLICATE of bug 324121

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 324121
9 years ago
9 years ago

People

(Reporter: Clare Bayley, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

9 years ago
When Firefox attempts to update and makes an extension compatability check, it only checks the local version information. It should check to see if a remote update or new remote version information is available that will make the extension compatible with the version of Firefox being installed.
Which point in the upgrade process are you talking about? That no remote check is performed when manually checking for app updates is already filed as bug 434155.
Assignee: cbayley → nobody
Status: ASSIGNED → NEW
Component: Extension Compatibility → Software Update
QA Contact: extension.compatibility → software.update
Version: 3.0 Branch → Trunk
(Reporter)

Comment 2

9 years ago
Darn, missed that one. This one is for both manual 'Check for Updates' checks and for automatic background checks. Could probably just use 434155 though.
Bug 434465 has a small note about the background update check failing, but by all means take care of them both in one go!
(Reporter)

Updated

9 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

9 years ago
Should I do that here then, for full disclosure of the problem?... ::still not sure how this whole bugzilla thing works:: I've almost got a patch ready to submit.
(Reporter)

Comment 5

9 years ago
Created attachment 329500 [details] [diff] [review]
New UpdateWithSpecifiedVersion function for checking remote extension compatability: WIP

Implemented new UpdateWithSpecifiedVersion function that takes in the version of the app and platform that are being updated to, and uses them for ui compatability checks instead of the current app/platform version. It also takes a boolean so it doesn't modify remote information.

The old update function hasn't changed - it just passes in false and null for the above information, which the ChekcForUpdates function catches and replaces with the default values.
Assignee: nobody → cbayley
(Reporter)

Comment 6

9 years ago
Comment on attachment 329500 [details] [diff] [review]
New UpdateWithSpecifiedVersion function for checking remote extension compatability: WIP

still a wip.
Attachment #329500 - Attachment description: New UpdateWithSpecifiedVersion function for checking remote extension compatability → New UpdateWithSpecifiedVersion function for checking remote extension compatability: WIP
Attachment #329500 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
This bug is in the features list for Firefox 3.1. Asking for blocking.
Flags: blocking1.9.1?
Summary: Firefox upgrades don't check for remote extension compatability → Firefox upgrades don't check for remote extension compatibility
Though the UI is part of App Update this needs to be provided by an interface
of the Add-ons Manager code so moving over there where the actual work needs to
be done.
Assignee: cbayley → nobody
Status: ASSIGNED → NEW
Component: Application Update → Add-ons Manager
QA Contact: software.update → extension.manager
This is the same as bug 324121 which has been around longer so marking dupe. I have Clare's WIP patches and will be adding them over there.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking1.9.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 324121
Status: RESOLVED → VERIFIED
Target Milestone: mozilla1.9.1 → ---
You need to log in before you can comment on or make changes to this bug.