[CSS LOADER]second-level imported css files applied randomly when also imported by another stylesheet

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: bzbarsky)

Tracking

1.9.0 Branch
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0

When a stylesheet imports a second stylesheet, which imports a third stylesheet file AND another stylesheet imports the second stylesheet too the rules of the third stylesheet are applied randomly.

Reproducible: Always

Actual Results:  
Reloading the page will sometimes bring the rules from the third stylesheet to the document.


This wasn't the case in Gecko 1.8. This should be fixed soon, since it may break some websites.
Version: unspecified → 1.9.0 Branch
Summary: second-level imported css files applied randomly when also imported by another stylesheet → [CSS LOADER]second-level imported css files applied randomly when also imported by another stylesheet
Fixing bug 436261 should fix this.
Depends on: 436261
Please attach the testcase to the bug so we can make sure it doesn't go away.
Posted file testcase
Fabian, thank you!
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
This isn't a Windows-only issue. I've changed to "All" in the hope it will be fixed till next release.
Fixed by checkin for bug 183348.
Assignee: nobody → bzbarsky
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.