<search-editor.properties> misses |RemoveCategoryTitle|

VERIFIED FIXED in seamonkey2.0a1

Status

SeaMonkey
Sidebar
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

({regression})

Trunk
seamonkey2.0a1
regression
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071502 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

1. Press the "Delete" button.
1r.
{{
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://communicator/content/search/search-editor.js :: RemoveCategory :: line 554"  data: no]
}}

Bug 362905 did not add this "property" :-(
(Assignee)

Comment 1

10 years ago
Created attachment 329807 [details] [diff] [review]
(Av1) </suite/*/common/search/*>

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071502 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

*Add missing property.
*Convert files to |<stringbundle/>|.

Unrelated:
*Rewrite a |promptService| definition.
*Remove an unwanted |new| in another property.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #329807 - Flags: superreview?(neil)
Attachment #329807 - Flags: review?(neil)

Comment 2

10 years ago
Comment on attachment 329807 [details] [diff] [review]
(Av1) </suite/*/common/search/*>

>-var promptService = Components.classes["@mozilla.org/embedcomp/prompt-service;1"].getService();
>-promptService = promptService.QueryInterface(Components.interfaces.nsIPromptService);
Actually I think it would be better to init this in doLoad too.

>-NewCategoryPrompt=Enter the new category name:
>+NewCategoryPrompt=Enter the category name:
In the new l10n world you have to be careful when tweaking the text of strings, since compare-locales doesn't identify the change for you. However in this case I hope it's sufficiently minor that we can get away with it ;-)
Attachment #329807 - Flags: superreview?(neil)
Attachment #329807 - Flags: superreview+
Attachment #329807 - Flags: review?(neil)
Attachment #329807 - Flags: review+
(Assignee)

Comment 3

10 years ago
Created attachment 329809 [details] [diff] [review]
(Av1a) </suite/*/common/search/*>

Av1, with comment 2 suggestion(s).
Attachment #329807 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Flags: in-litmus-
Keywords: checkin-needed

Comment 4

10 years ago
Landed attachment #329809 [details] [diff] [review]:

http://hg.mozilla.org/index.cgi/comm-central/rev/4f914bfb27db
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 5

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008072716 SeaMonkey/2.0a1pre] (home made) (W2Ksp4)

V.Fixed
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Flags: in-litmus- → in-testsuite-
You need to log in before you can comment on or make changes to this bug.