In </suite/*>, "use a xul <stringbundle/> instead of including the strres.js code"

RESOLVED FIXED in seamonkey2.0a1

Status

SeaMonkey
General
--
trivial
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
seamonkey2.0a1
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments, 3 obsolete attachments)

(Assignee)

Description

10 years ago
"Found 15 matching lines in 12 files"

minus the 2 <pref-languages*.xul> ready for checkin in bug 56680.

***

<pageInfo.xul> should be (kept in) sync' with the one from (FF) bug 445374.
(Assignee)

Updated

10 years ago
Depends on: 445429
(Assignee)

Updated

10 years ago
Depends on: 445438
(Assignee)

Updated

10 years ago
Depends on: 445467
(Assignee)

Comment 1

10 years ago
Created attachment 329904 [details] [diff] [review]
(Av1) </suite/common/permissions/*.xul>

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071502 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
Assignee: general → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #329904 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 2

10 years ago
Created attachment 329942 [details] [diff] [review]
(Bv1) </suite/browser/pageinfo/*>
[Checkin: Comment 13]

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071502 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
Attachment #329942 - Flags: review?(db48x)
Comment on attachment 329942 [details] [diff] [review]
(Bv1) </suite/browser/pageinfo/*>
[Checkin: Comment 13]

looks good, r=db48x
Attachment #329942 - Flags: review?(db48x) → review+
(Assignee)

Updated

10 years ago
Flags: in-litmus-
Keywords: checkin-needed
Whiteboard: [c-n: Bv1 // Leave opened]
Target Milestone: --- → seamonkey2.0alpha
(Assignee)

Comment 4

10 years ago
Created attachment 330022 [details] [diff] [review]
(Cv1) <urlbarBindings.xml>

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071502 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

It used the <strres.js> from (shared) <utilityOverlay.xul>,
which I'll submit a later/separate patch for.
Attachment #330022 - Flags: review?(db48x)
(Assignee)

Updated

10 years ago
Depends on: 445753
(Assignee)

Updated

10 years ago
Depends on: 445790
(Assignee)

Updated

10 years ago
Depends on: 445807
(Assignee)

Comment 5

10 years ago
Created attachment 330080 [details] [diff] [review]
(Av1a) </suite/common/permissions/*.xul>

Av1, using |getStringBundle()| from Toolkit <contentAreaUtils.js> ;-)
Attachment #329904 - Attachment is obsolete: true
Attachment #330080 - Flags: review?(iann_bugzilla)
Attachment #329904 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 6

10 years ago
Created attachment 330082 [details] [diff] [review]
(Av1b) </suite/common/permissions/*.xul> 
[Checkin: Comment 14]

Av1a, with s/Toolkit//, as SeaMonkey uses its forked file :-|
Attachment #330080 - Attachment is obsolete: true
Attachment #330082 - Flags: review?(iann_bugzilla)
Attachment #330080 - Flags: review?(iann_bugzilla)

Updated

10 years ago
Attachment #330082 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

10 years ago
Whiteboard: [c-n: Bv1 // Leave opened] → [c-n: Av1b, Bv1 // Leave opened]
(Assignee)

Comment 7

10 years ago
Created attachment 330160 [details] [diff] [review]
(Dv1) </suite/browser/*.xul>
[Checkin: Comment 21]

2 useless includes, as all (function) callers have been fixed in other patches.
Attachment #330160 - Flags: superreview?(jag)
Attachment #330160 - Flags: review?(jag)
(Assignee)

Comment 8

10 years ago
Created attachment 330161 [details] [diff] [review]
(Ev1) </suite/common/bookmarks/*.xul> 
[Checkin: Comment 15]

2 useless includes, as all (function) callers have been fixed in other patches.
Attachment #330161 - Flags: review?(db48x)
Comment on attachment 330161 [details] [diff] [review]
(Ev1) </suite/common/bookmarks/*.xul> 
[Checkin: Comment 15]

would have liked to see this all as one patch, but it's ok. r=db48x
Attachment #330161 - Flags: review?(db48x) → review+
(Assignee)

Updated

10 years ago
Whiteboard: [c-n: Av1b, Bv1 // Leave opened] → [c-n: Av1b, Bv1, Ev1 // Leave opened]
Comment on attachment 330022 [details] [diff] [review]
(Cv1) <urlbarBindings.xml>

the searchValue setter could be simplified to use fewer variables, but it's no matter. r=db48x
Attachment #330022 - Flags: review?(db48x) → review+
(Assignee)

Comment 11

10 years ago
Created attachment 330751 [details] [diff] [review]
(Cv1a) <urlbarBindings.xml>
[Checkin: Comment 16]

Cv1, with comment 10 suggestion(s).
Attachment #330022 - Attachment is obsolete: true
Attachment #330751 - Flags: review?(db48x)

Updated

10 years ago
Attachment #330751 - Flags: review?(db48x) → review+
(Assignee)

Updated

10 years ago
Whiteboard: [c-n: Av1b, Bv1, Ev1 // Leave opened] → [c-n: Av1b, Bv1, Cv1a, Ev1 // Leave opened]

Comment 12

10 years ago
Serge, you still need sr on Av1b, Bv1, Cv1a, Ev1
Keywords: checkin-needed

Comment 13

10 years ago
Comment on attachment 329942 [details] [diff] [review]
(Bv1) </suite/browser/pageinfo/*>
[Checkin: Comment 13]

http://hg.mozilla.org/comm-central/index.cgi/rev/b247c1a31380
Attachment #329942 - Attachment description: (Bv1) </suite/browser/pageinfo/*> → (Bv1) </suite/browser/pageinfo/*> (Checked in)

Comment 14

10 years ago
Comment on attachment 330082 [details] [diff] [review]
(Av1b) </suite/common/permissions/*.xul> 
[Checkin: Comment 14]

http://hg.mozilla.org/comm-central/index.cgi/rev/dd2b64479966
Attachment #330082 - Attachment description: (Av1b) </suite/common/permissions/*.xul> → (Av1b) </suite/common/permissions/*.xul> (Checked in)

Comment 15

10 years ago
Comment on attachment 330161 [details] [diff] [review]
(Ev1) </suite/common/bookmarks/*.xul> 
[Checkin: Comment 15]

http://hg.mozilla.org/comm-central/index.cgi/rev/5a71d1e8b086
Attachment #330161 - Attachment description: (Ev1) </suite/common/bookmarks/*.xul> → (Ev1) </suite/common/bookmarks/*.xul> (Checked in)

Comment 16

10 years ago
Comment on attachment 330751 [details] [diff] [review]
(Cv1a) <urlbarBindings.xml>
[Checkin: Comment 16]

http://hg.mozilla.org/comm-central/index.cgi/rev/cb66b1639351
Attachment #330751 - Attachment description: (Cv1a) <urlbarBindings.xml> → (Cv1a) <urlbarBindings.xml> (Checked in)

Updated

10 years ago
Whiteboard: [c-n: Av1b, Bv1, Cv1a, Ev1 // Leave opened] → [Leave opened]
(Assignee)

Updated

10 years ago
Attachment #330082 - Attachment description: (Av1b) </suite/common/permissions/*.xul> (Checked in) → (Av1b) </suite/common/permissions/*.xul> [Checkin: Comment 14]
(Assignee)

Updated

10 years ago
Attachment #330161 - Attachment description: (Ev1) </suite/common/bookmarks/*.xul> (Checked in) → (Ev1) </suite/common/bookmarks/*.xul> [Checkin: Comment 15]
(Assignee)

Updated

10 years ago
Attachment #330751 - Attachment description: (Cv1a) <urlbarBindings.xml> (Checked in) → (Cv1a) <urlbarBindings.xml> [Checkin: Comment 16]
(Assignee)

Updated

10 years ago
Attachment #329942 - Attachment description: (Bv1) </suite/browser/pageinfo/*> (Checked in) → (Bv1) </suite/browser/pageinfo/*> [Checkin: Comment 13]
(Assignee)

Updated

10 years ago
Blocks: 445374
No longer depends on: 445374
Whiteboard: [Leave opened]
(Assignee)

Comment 17

9 years ago
Created attachment 331619 [details] [diff] [review]
(Fv1) <urlbarBindings.xml> missing ")"
[Checkin: Comment 18]

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008072911 SeaMonkey/2.0a1pre] (home made) (W2Ksp4)

Fixes
{{
Error: missing ) after argument list
Source File: chrome://navigator/content/urlbarBindings.xml
Line: 392, Column: 68
Source Code:
                "searchFor", [kids[i].getAttribute("name"), val], 2); 
}}
caused by Cv1a patch :-<
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [c-n: Fv1 // Leave opened]

Comment 18

9 years ago
Comment on attachment 331619 [details] [diff] [review]
(Fv1) <urlbarBindings.xml> missing ")"
[Checkin: Comment 18]

I landed this

Comment 19

9 years ago
Serge - is there anything left to do here or can this be closed as fixed?
Keywords: checkin-needed
Whiteboard: [c-n: Fv1 // Leave opened]
(Assignee)

Updated

9 years ago
Attachment #331619 - Attachment description: (Fv1) <urlbarBindings.xml> missing ")" → (Fv1) <urlbarBindings.xml> missing ")" [Checkin: Comment 18]
(Assignee)

Comment 20

9 years ago
(In reply to comment #19)

Waiting for Dv1 patch (review).
(Assignee)

Updated

9 years ago
Attachment #330160 - Flags: superreview?(neil)
Attachment #330160 - Flags: superreview?(jag)
Attachment #330160 - Flags: review?(neil)
Attachment #330160 - Flags: review?(jag)

Updated

9 years ago
Attachment #330160 - Flags: superreview?(neil)
Attachment #330160 - Flags: superreview+
Attachment #330160 - Flags: review?(neil)
Attachment #330160 - Flags: review+
(Assignee)

Updated

9 years ago
Flags: in-litmus- → in-testsuite-
Keywords: checkin-needed
Whiteboard: [c-n: Dv1]
(Assignee)

Comment 21

9 years ago
Comment on attachment 330160 [details] [diff] [review]
(Dv1) </suite/browser/*.xul>
[Checkin: Comment 21]

http://hg.mozilla.org/index.cgi/comm-central/rev/8a3e54a9ac15
Attachment #330160 - Attachment description: (Dv1) </suite/browser/*.xul> → (Dv1) </suite/browser/*.xul> [Checkin: Comment 21]
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [c-n: Dv1]
(Assignee)

Updated

8 years ago
Depends on: 445831
You need to log in before you can comment on or make changes to this bug.