Need a pref to disable the new ctrl+tab preview panel

VERIFIED FIXED in Firefox 3.1a1

Status

()

defect
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: u88484, Assigned: dao)

Tracking

Trunk
Firefox 3.1a1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

11 years ago
There should be a preference somewhere to disable the new ctrl+tab preview panel.  Maybe just changing browser.ctrlTab.previewsCount to 0 should disable it.
Reporter

Updated

11 years ago
Blocks: 395980
Assignee

Comment 1

11 years ago
Note that there are alternate shortcuts for the old behavior, depending on which OS you're using:
http://support.mozilla.com/en-US/kb/Keyboard+shortcuts

Comment 2

11 years ago
I agree with the preference. Users may not want to display tabs in recently visited order and the Ctrl+Tab does take up a lot of CPU when switching tabs quickly which means older machines will notice even more slow down.

As for the additional shortcuts, I only just found out after reading that link so most people probably won't even know about it.
Assignee

Updated

11 years ago
Duplicate of this bug: 445981
Duplicate of this bug: 446024
Assignee

Updated

11 years ago
Assignee: nobody → dao
Assignee

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 5

11 years ago
(In reply to comment #0)
> There should be a preference somewhere to disable the new ctrl+tab preview
> panel.  Maybe just changing browser.ctrlTab.previewsCount to 0 should disable
> it.
> 

At the moment, changing the about:config string doesn't do anything at all -- maybe this is the problem.  increasing the number doesnt change anything, nor does decreasing it.  shouldn't be hard to get this in the next build.

Comment 6

11 years ago
forcing someone to go through recently displayed order is about the least logical behavior possible.  if you can see that the tab you want is three tabs to the left, it used to be that a quick ctrl-shift, tab, tab, tab, would have you there instantaneously.  now with the latest functionality, you have to sit scrolling through thumbnails to  find what the page looks like. its lunacy.

Comment 7

11 years ago
in fact, is it possible for someone to post the most recent nightly before this transition?  I will have to stop using the nightlies until this gets resolved.

Comment 8

11 years ago
sorry for the string comments, but I just wanted to point out that the largest part of the problem here is the default tab switching order.  You should not have to remember what order you were looking at tabs in, in order to get back to the tab.  it is all fine and well if you have 3 tabs up, but if you consistently have 10-20 tabs up, that is ridiculous.
Reporter

Comment 9

11 years ago
That is another bug, check the dependcies of bug 395980 for all the open "issues"

Comment 10

11 years ago
after reading through that, I am not sure that you are right.  The only thing I see with respect to tab order is the loss of MRU on restore.  The MRU tab order was only implemented with this new preview panel functionality.  They are part and parcel to each other, and need to be resolved.  the pref option to disable the preview panel ought also to include one to select either logical or MRU order.

Comment 11

11 years ago
I too think 'most recent tab order' is for most users, an unnecessary and unwanted feature that would be best left to an extension. I voiced my opinions many months ago in 395980. However, as certain people seem to have pushed for this to go through as is, the least they could do is mandate that the feature have a plainly-discoverable TOGGLE that switches the order-type.

Why a toggle? Well the switcher by default now utilizes a behaviour that is COMPLETELY ALIEN to all Firefox users, and while you could put a pref in about:config or add an option for it in the Options panel, how are people to know it's there?

Inevitably, a large percentage of users who are shocked that Ctrl+Tab now does something they don't expect it to (and don't want it to) will end up posting on a messageboard "I hate this new feature. How do I turn it off?". Yes, even if the feature is documented on SUMO (Help->Help Contents).
Assignee

Comment 12

11 years ago
Posted patch patchSplinter Review
Attachment #330289 - Flags: review?(gavin.sharp)

Comment 13

11 years ago
(In reply to comment #5)
> (In reply to comment #0)
> > There should be a preference somewhere to disable the new ctrl+tab preview
> > panel.  Maybe just changing browser.ctrlTab.previewsCount to 0 should disable
> > it.
> > 
> 
> At the moment, changing the about:config string doesn't do anything at all --
> maybe this is the problem.  increasing the number doesnt change anything, nor
> does decreasing it.  shouldn't be hard to get this in the next build.
> 
It does something for me when increasing it. Haven't tried decreasing it though.
Attachment #330289 - Flags: review?(gavin.sharp) → review+
Assignee

Comment 14

11 years ago
http://hg.mozilla.org/index.cgi/mozilla-central/rev/a4ddc249593b
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a1
Assignee

Updated

11 years ago
Blocks: 445499
Depends on: 446199
Dao, the new pref is not listed under about:config. Shouldn't it be there when your patch added it to browser/app/profile/firefox.js? It also happens or new profiles. Only browser.ctrlTab.previewsCount and browser.ctrlTab.smoothScroll are listed. I ran the test with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1pre) Gecko/2008071806 Minefield/3.1a1pre ID:2008071806

Comment 16

11 years ago
(In reply to comment #15)
> Dao, the new pref is not listed under about:config. Shouldn't it be there when
> your patch added it to browser/app/profile/firefox.js? It also happens or new
> profiles. Only browser.ctrlTab.previewsCount and browser.ctrlTab.smoothScroll
> are listed. I ran the test with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5;
> en-US; rv:1.9.1a1pre) Gecko/2008071806 Minefield/3.1a1pre ID:2008071806
> 
Try updating your Minefield version. Should be there on 2008072003 build.
Thanks for pointing that out. I started the wrong version.

Verified with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1pre) Gecko/2008072002 Minefield/3.1a1pre ID:2008072002

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008072003 Minefield/3.1a1pre ID:2008072003
Status: RESOLVED → VERIFIED

Comment 18

11 years ago
WFM 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008072102 Minefield/3.1a1pre ID:2008072102

Does require a restart though, which would be annoying if this ever becomes a full preference in one of the options boxes eventually.
Assignee

Updated

11 years ago
No longer blocks: 445499

Updated

11 years ago
Duplicate of this bug: 448684
Could I request that we get some UI in the prefs pane for this? The string could be something like "Control-Tab selects recently-visited tabs."

For many users, the "new" Ctrl-Tab order is counter-intuitive; it is certainly against the established MDI conventions, since in many use cases, Ctrl-Tab will have the effect of shifting left instead of right.
Assignee

Comment 21

11 years ago
(In reply to comment #20)
> Could I request that we get some UI in the prefs pane for this? The string
> could be something like "Control-Tab selects recently-visited tabs."

I don't think that's needed, as I expect mostly advanced users to prefer the old way. Feel free to file a new bug, though.

Comment 22

11 years ago
The fix does not currently work in 3.1b2pre. To a lot of advanced users and not advanced users (i.e. my wife) will find this a very missing feature. Your presumption that only advanced users like this is a lacking one. I stress the need for having a toggle button in tools->options.

Comment 23

11 years ago
the new config is browser.ctrlTab.previews  -- set it to false.
You need to log in before you can comment on or make changes to this bug.