Ctrl-Tab preview should allow tabs to be clicked on

VERIFIED FIXED in Firefox 3.1a2

Status

()

enhancement
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: nightstalkerz, Assigned: dao)

Tracking

Trunk
Firefox 3.1a2
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008071603 Minefield/3.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008071603 Minefield/3.1a1pre

When using Ctrl-Tab previews, they should be clickable so that the user can go to the specific tab quicker.

Reproducible: Always

Steps to Reproduce:
1. Press Ctrl + Tab
2. Try to click on a tab preview
3.
Actual Results:  
Nothing happens.

Expected Results:  
The tab clicked on will be displayed.
Assignee

Comment 1

11 years ago
Ctrl-Tab is keyboard-orientated by design. Would prefer to wontfix this in favor of bug 436304.
Blocks: 395980
Keywords: uiwanted
Reporter

Comment 2

11 years ago
Most users won't know about it and will probably complain if they can't click on something which looks like its clickable.
Dao, on OS X its a common functionality. Switching between application by using Cmd+Tab let you choose the application with the mouse. The desired application under the cursor gets a hover style. That's a wonderful enhancement which I really miss on Windows.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
Version: unspecified → Trunk
Reporter

Comment 4

11 years ago
You can do the same thing on Vista as well. This should be put in for OS integration.
Assignee

Comment 5

11 years ago
Posted patch patch (obsolete) — Splinter Review
trivial patch

I'm not going to request ui-review, since beltzner is swamped and this is an unobtrusive feature that won't bother anyone who doesn't want to use it. Anything that goes beyond this (e.g. hover styling) can be handled in new bugs.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #333385 - Flags: review?(gavin.sharp)
Assignee

Comment 6

11 years ago
Posted patch patch v2Splinter Review
do stopScroll() before accessing this.selected. This is the correct behavior when Tab is released while scrolling.
Attachment #333385 - Attachment is obsolete: true
Attachment #333386 - Flags: review?(gavin.sharp)
Attachment #333385 - Flags: review?(gavin.sharp)
Attachment #333386 - Flags: review?(gavin.sharp) → review+
Assignee

Comment 7

11 years ago
http://hg.mozilla.org/index.cgi/mozilla-central/rev/cbc68938b7cb
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: uiwanted
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a2
Dao, using the mouse to click on a preview doesn't work neither on Windows nor OS X with the latest nightly build.

If you want to get it to work on Windows XP you have to hold down the left mouse button while releasing the ctrl key. Now the crtl-tab panel is still visible and you can click a preview. Using OS X it doesn't work at all. Releasing the ctrl key closes the ctrl-tab panel.

With the tryserver build for all tabs preview it works fine as long as you don't have pressed the ctrl key. So I think we shouldn't catch the mouse click event because ctrl is clicked.

I think we should reopen the bug because the feature doesn't really work yet.
Reporter

Comment 9

11 years ago
Ctrl + Tab works for me. Hold down Ctrl, then press tab. Release tab and you shpuld be able to click on the previews.

Works on Vista and XP.
Assignee

Comment 10

11 years ago
WFM too.
(In reply to comment #9)
> Ctrl + Tab works for me. Hold down Ctrl, then press tab. Release tab and you
> shpuld be able to click on the previews.
> 
> Works on Vista and XP.

I'm not the only one who is affected by this. Marcia has the same problems in getting it to work on Windows and OS X. Probably she will comment soon. Until then could you try to re-run the test with a fresh profile? Does it still work for you? No idea if this is VmWare related why it doesn't work for us. But at least on OS X there is no other software which can interferes us here.
Ok, I got it to work on Windows XP running inside VmWare. The problem here is that you shouldn't have to be active OS X mouse actions. This option can be turned of in the VmWare preferences.

But on OS X it's a bit different. Here the combination ctrl + left click is used to open the context menu. Because we don't have such a menu we can't see anything. Dao, shall we also enable the control modifier here? 
(In reply to comment #12)
> But on OS X it's a bit different. Here the combination ctrl + left click is
> used to open the context menu. Because we don't have such a menu we can't see
> anything. Dao, shall we also enable the control modifier here? 

Filed that as bug 451604.

Meanwhile I can verify this enhancement with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080821034539 Minefield/3.1a2pre ID:20080821034539

We should add it to Litmus after the new testsuite has been created.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Henrik: Thanks for debugging the issue on Windows. I was running Vista in a VM, and now I understand why it was not working.
https://litmus.mozilla.org/show_test.cgi?id=7038 added to Litmus
Flags: in-litmus? → in-litmus+
We seem to have hidden this behind a pref (?) now and it is off by default. The testcase doesn't take this into account.
(In reply to comment #16)
> We seem to have hidden this behind a pref (?) now and it is off by default. The
> testcase doesn't take this into account.

This testcase is disabled currently on Litmus.
Only if you just disabled it. It was in the Firefox 3.6 FFT run with all the other tab cases.
You need to log in before you can comment on or make changes to this bug.