Closed Bug 445560 Opened 16 years ago Closed 15 years ago

html pushlog should fold merge changesets into one line

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ted, Assigned: sid)

References

()

Details

Attachments

(4 files, 4 obsolete files)

The URL contains a mockup. After some discussion, I think the simplest approach here is "If any changeset in this push is a merge (has multiple parents), then fold the entire push into a single entry". Anything more complicated involves actually traversing the graph, which sort of sucks.
Assignee: ted.mielczarek → nobody
Component: Release Engineering: Future → Hg: Customizations
QA Contact: release → hg.customizations
Assignee: nobody → ted.mielczarek
Jesse asked on IRC, so to clarify, my intent is actually only to do this folding if the changeset is a merge, and was pushed as a group of >5 changesets. (5 is just a convenient number so we don't fold small groups of changesets.)
This patch first requires ted's patch for pushlog-feed.py (push-folding.patch). It makes it so that when a user clicks on a certain [Expand] link only the hidden rows for that link are shown
Attachment #348447 - Flags: review?(ted.mielczarek)
This patch first requires ted's patch for hg_templates (push-folding.patch). It makes it so that when a user clicks on a certain [Expand] link only the hidden rows for that link are shown
Attachment #348448 - Flags: review?(ted.mielczarek)
Attachment #348447 - Flags: review?(ted.mielczarek) → review-
Attachment #348448 - Flags: review?(ted.mielczarek) → review-
Comment on attachment 348448 [details] [diff] [review]
 Patch that fixes certain functionality for the earlier patch (hg_templates) submitted by ted

This is cool, and it's very close, I just have a few changes you'll need to make. First, you can't have multiple elements with the same id, it's not allowed. Nevermind the fact that it works. :) You can work around this by using a class instead. Second, I think instead of using the date, you should just use "id", which is a unique integer ID per push (group of changesets).
Would it be possible to use one tbody per push, with the left-hand column (the one with the name/date) using a <td rowspan="0">?
Also, would it be possible as a user to set this to either happen or not once and not have to unfold all the changesets manually if I always want them unfolded?
Note: Requires ted's patch for hgpoller
- Now uses ids instead of dates as a unique identifier
- Now uses class to store the unique identifiers
Attachment #348447 - Attachment is obsolete: true
Attachment #349831 - Flags: review?(ted.mielczarek)
Note: Requires ted's patch for hgpoller
- Now uses ids instead of dates as a unique identifier
- Now uses class to store the unique identifiers
Attachment #348448 - Attachment is obsolete: true
Attachment #349832 - Flags: review?(ted.mielczarek)
Ignore comment #10. I meant to say:

Note: Requires ted's patch for hg_templates
Comment on attachment 349831 [details] [diff] [review]
Patch for hgpoller to fix expand/collapse functionality

+                     "Id": id

Any reason this is capitalized?
Attachment #349831 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 349832 [details] [diff] [review]
Patch for hg_templates to fix expand/collapse functionality

+    var id = $(this).attr("class");

Could you rename this to 'pushid' or something clearer? Also, remove the XXX comment, since you fixed it.

r=me with those changes.
Attachment #349832 - Flags: review?(ted.mielczarek) → review+
Assignee: ted.mielczarek → sid
Changed variables name Id to id

Note: this patch requires WIP patch for hgpoller
Attachment #349831 - Attachment is obsolete: true
Attachment #363534 - Flags: review?(ted.mielczarek)
Changed the variable name id to pushid

Note: this patch requires WIP patch for templates
Attachment #349832 - Attachment is obsolete: true
Attachment #363535 - Flags: review?(ted.mielczarek)
Attachment #363534 - Flags: review?(ted.mielczarek) → review+
Attachment #363535 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 363535 [details] [diff] [review]
Patch for hg_templates to fix expand/collapse functionality 

I tweaked this slightly to change "identifier" to "id", and I changed the call to "substring" to use a regex.
That is to say, I pushed both of these changes:
http://hg.mozilla.org/hg_templates/rev/0ecbdfad931d
http://hg.mozilla.org/users/bsmedberg_mozilla.com/hgpoller/rev/c88bf6c80d4e
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
This is kind of frustrating, since merges happen all the time, not just in "merge" situations.
Hm, apparently we didn't implement this as I said in comment 1. I wanted this to only fold merges of >5 changesets, so the simple "pushed one changeset but merged" case didn't get folded. I'll file a followup on that.
Depends on: 486939
Depends on: 655463
Product: mozilla.org → Release Engineering
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: