test_not-opener.html fails intermittently on Linux unittest VM

RESOLVED DUPLICATE of bug 451090

Status

()

Core
General
RESOLVED DUPLICATE of bug 451090
10 years ago
5 years ago

People

(Reporter: ted, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
For some reason this test is unreliable running on a VM, it fails intermittently like so:

*** 13276 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
*** 13277 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
*** 13278 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2

Colin, could you provide some insight as to why the test would fail in this manner? We've seen that a lot of timing-related assumptions fail when running unittests in a VM, but I don't understand this test well enough to see what's happening. If need be, we can check in some debug log statements in the test to help track it down.
(Reporter)

Comment 1

9 years ago
Happened again:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1218813548.1218817694.2804.gz

Comment 2

9 years ago
Sounds like the VM is slow and triggering a race condition.  I'm out of the country, but when I get back I'll try to figure out if this is a race in the test or not.  Any ideas how to debug this beyond staring at the code?
(Reporter)

Comment 3

9 years ago
We can check in dump statements to do printf-style debugging if you'd like. Sprinkle them liberally to figure out what's going on, then we'll remove them when we fix it.

Comment 4

9 years ago
See also Bug 451090.
(In reply to comment #4)
> See also Bug 451090.

+/- related: same file, different error.
(Reporter)

Comment 6

9 years ago
Adam says these are both the same bug in the test.
No longer blocks: 408052, 438871
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451090
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239534294.1239541221.17434.gz
Linux mozilla-central unit test
*** 29344 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
*** 29345 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1240230663.1240235031.29743.gz
Linux mozilla-1.9.1 unit test on 2009/04/20 05:31:03
Blocks: 438871
Whiteboard: [orange]
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.