Display sort order indicator arrow direction reversed

RESOLVED DUPLICATE of bug 227455

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 227455
10 years ago
10 years ago

People

(Reporter: Anthony Harmon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_4; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: version 2.0.0.14 (20080421)

Thunderbird's sort arrow direction is reversed from that of other programs, such as Apple Mail.

"Down" does not sort entries by latest-to-earliest order; it goes the opposite. This is strictly a UI guideline error, but other programs follow the Apple Mail example, which makes sense in this case.

Reproducible: Always

Steps to Reproduce:
1. Click on Date column so that display sort arrow is facing "DOWN"
2. Email entries will be sorted in earliest-to-latest order, being reversed.
3.
Actual Results:  
Mail that was received earliest appears at the top of the list

Expected Results:  
Mail that was received later should be at the top of the list

In programs that use the UP/DOWN arrows as sorting indicators, DOWN always means "latest-to-earliest"

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 227455
You need to log in before you can comment on or make changes to this bug.