RFE: Allow to rename attachments during mail composition (renaming attachments)

RESOLVED DUPLICATE of bug 190298

Status

enhancement
RESOLVED DUPLICATE of bug 190298
11 years ago
11 years ago

People

(Reporter: bugzilla2007, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Version 2.0.0.14 (20080421)

When I compose a mail and attach some files, I often want to change the file name after attaching, since my personal file naming patterns are usually not suitable for the recipient. I can think of numerous scenarios where the possibility to rename attachments before sending the mail will be beneficial both for private and business use.

Reproducible: Always

Steps to Reproduce:
1. Compose mail and attach a file named "My file name, not right for recipient (Version 35).doc"
2. Press F2 or try context menu to rename the attachment in attachment panel of message compose window to something more sensible like "New file name for recipient.doc"
3.
Actual Results:  
Can't rename attachments after they are attached.
Need to delete attachment, rename original file in my system, attach again, rename original file back to old filename in my system - very cumbersome!

Expected Results:  
Attachments should be renamable (in the attachment panel) during composition time

Comment 1

11 years ago
that's already present in Thunderbird 3.0, which is in early alpha
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 190298
You need to log in before you can comment on or make changes to this bug.