Closed Bug 446452 Opened 14 years ago Closed 13 years ago

RFE: Attachment panel should have alternative view modes (view details of attached files)

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 360647

People

(Reporter: thomas8, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 3.0a1 (2008050715)

Attachment panel both for received messages and at compose time should offer alternative view mode(s), in particular: "View details" (like in windows explorer). See attached screenshot to see how this could look like. The special benefit of this feature would be to see more files at once, to see long file names in full, to see the the size of attachments, or other relevant properties - all in one spot, in an intuitive explorer-like fashion.

At present, attachment view for incoming messages is set to large icons by default. Small icons are only available through config.editor (i.e. unavailable to the average user). Long filenames are abbreviated ("File with lon...ame.doc"), user needs to hover over each icon to see full file name, which is a nuisance with multiple attachments. It is not possible to see long filenames of all attached files in overview. Attachment panels have been designed to look like explorer window panel, so alternative view mode(s) would be a logical and intuitive improvement.


Reproducible: Always

Steps to Reproduce:
1. Open (or compose) mail with lots of attachments
2. Try to figure out the file size of individual attachments
3. Try to see long file names in full
4. Try to see lots of attachments in an orderly top-down list, without resizing attachment pane to half screen size
5. Try to order attachments by file name, file size, type etc.

Actual Results:  
All you get is a static multi-column list of big icons with abbreviated file names.
2. File size is not available for individual attachments.
3. Full long file names cannot be viewed for multiple files at once (only hover tooltip)
4. clear-view top-down list not available
5. You cannot sort attachments according to any criterion


Expected Results:  
Right-clicking in attachment pane should offer the following command in the context menu:
View > Large Icons | Small Icons | Details | ...

Activating "details" view mode (like in windows explorer)...
...will return a nicely ordered list of all attachments in detail, including full long names, sizes, types...
...will enable the user to sort that list of attachments according to a criterion of his choice (esp. name or size).
Here's a draft screenshot illustrating the proposal for attachment panel in main mail window's message preview pane. In the same way, "View Details" should also be implemented for compose mode.
Summary: Attachment panel should have alternative view modes (view details of attached files) → RFE: Attachment panel should have alternative view modes (view details of attached files)
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360647
You need to log in before you can comment on or make changes to this bug.