Can't save tasks neither events once main Sunbird window is closed (and all changes are lost)

VERIFIED DUPLICATE of bug 390293

Status

Calendar
General
VERIFIED DUPLICATE of bug 390293
10 years ago
10 years ago

People

(Reporter: Denis BUCHER, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-CH; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: 

If I close the main Sunbird window while editing a task, or while editing an event, I can no longer save any changes. Neither the "Save and Close" button nor the "File|Save" menu item are doing anything. If, after trying to save the changes, I then close the task, the "Task has not been saved" warning does not appear. If I don't try to save the changes, the "Event has not been saved Save/Cancel/Discard" appears, but when clicking on Save then changes are lost anyway.

It's even worse : when reopening the Sunbird window, and clicking on "save" in the event, it still doesn't work...


Reproducible: Always

Steps to Reproduce:
1. Open a task OR an event. Make some changes.
2. Switch to main Sunbird window, and close it.
3. Click "Save and Close". Nothing seems to happen.
or
3. Select "File|Save" menu item.

4. Close task, e.g. by selecting "File|Close". Note "Task has not been saved"
warning does not appear.
5. Reopen main Sunbird window.
6. Reopen task. Note changes were not saved.

Actual Results:  
Changes made to the task have been lost.

Expected Results:  
Changes should have been saved.

System details:
* Windows XP Pro
* Sunbird 0.8 (latest version)
* Modules : CuteMenus 1.9.3, Google Agenda 0.4, Talkback 0.5

Warning : this bug is very similar to Bug 390293 but it is NOT A DUPLICATE :
=> The other bug is about Thunderbird, and all the comments are about solving the Thunderbird specific problem, but I think it's either two bugs either the same, but I would say that 390293 would be a duplicate of this one, not the opposite... At least this bug has nothing to do with "because the calendar code is loaded into the xul-context of Thunderbird's window"
In my opinion it is a duplicate of Bug 390293. In both cases the Sunbird/Thunderbird main window that contains the calendar components is closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390293
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.