Closed Bug 446620 Opened 13 years ago Closed 11 years ago

crash [@ nsXPCOMCycleCollectionParticipant::Unroot - nsNavHistoryResult::OnItemMoved]

Categories

(Firefox :: Bookmarks & History, defect)

3.0 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mardeg, Unassigned)

References

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

http://crash-stats.mozilla.com/report/index/7656296b-515e-11dd-bbbd-001a4bd43ed6


Reproducible: Didn't try

Steps to Reproduce:
1. click the star twice to bookmark a site then bring up the dialog to choose a folder.
2. go to click a folder to select it, but drag the folder by accident, dropping it within the dialog somewhere (perhaps onto another folder?)
3. pretty crash dialog :)
Actual Results:  
Click with the mouse moving was interpreted as a drag drop

Expected Results:  
A forgiving interface that knows a click drag is just an unco-ordinated click.
Version: unspecified → 3.0 Branch
This may be the same crash as bug 442397.
Signature	nsXPCOMCycleCollectionParticipant::Unroot(void*)
UUID	7656296b-515e-11dd-bbbd-001a4bd43ed6
Time	2008-07-13 21:35:16-07:00
Uptime	1559
Product	Firefox
Version	3.0
Build ID	2008052906
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 15 model 2 stepping 4
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x25975
Comments	accidentally dragged a folder while choosing one in the Star bookmarks dialog from the awesomebar star
Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsXPCOMCycleCollectionParticipant::Unroot 	nsCycleCollectionParticipant.cpp:74
1 	xul.dll 	nsNavHistoryResult::OnItemMoved 	mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp:4245
Keywords: crash
Summary: crash nsXPCOMCycleCollectionParticipant::Unroot(void*) xull.dll nsNavHistoryResult::OnItemMoved → crash [@ nsXPCOMCycleCollectionParticipant::Unroot - nsNavHistoryResult::OnItemMoved]
anyone able to reproduce this one resp. has clearer STRs?
i failed with Firefox/3.1b1pre ID:20080831162801 & Firefox/3.0.1 ID:2008070208 no matter how many folders i create/drag around in that dialog :-/.

@reporter: i presume you tried this extension-less resp. doublechecked with a new profile?!
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
I had a similar problem.
* created a new folder
* moved the folder to a different location in the bookmarks menu
* FF crashed

see 41c25147-7d26-11dd-9574-0013211cbf8a
Steps to reproduce:
1) 'Bookmarks' menu -> 'Organize Bookmarks...'
2) Go to the end of the 'Bookmark Menu' sub-folder
3) Right mouse click -> 'New Folder...', create the new folder
4) Drag and drop the new folder in the last position
5) Crash

bp-321acfbf-8640-4f5e-b05b-b12552081121
bp-83621ff5-c847-47f4-93f0-85bc20081120

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5pre) Gecko/2008111706 GranParadiso/3.0.5pre ID:2008111706
Seems the above steps don't always do it, better STR:

1) Go to http://www.google.ca
2) 'Bookmarks' menu -> 'Bookmark This Page', folder: 'Bookmark Menu', click 'Done'
3) 'Bookmarks' menu -> 'Organize Bookmarks...'
4) Go to the end of the 'Bookmark Menu' sub-folder
5) Right mouse click on the http://www.google.ca bookmark -> 'New Folder...', create the new folder with a unique name
6) Drag and drop the new folder in the last position
7) Crash, if it doesn't crash delete the bookmark http://www.google.ca and the new Folder and redo (in the same browsing session) steps 1 to 7
I've tried ten times to repeat steps with latest 3.1b2pre nightly, but i'm unable to cause a crash...
effectively i don't see any report for 3.1 with the same stack trace... could have been solved somewhere else
(In reply to comment #7)
> effectively i don't see any report for 3.1 with the same stack trace... could
> have been solved somewhere else

http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&query=nsXPCOMCycleCollectionParticipant%3A%3AUnroot(void*)&date=&range_value=1&range_unit=weeks&do_query=1&signature=nsXPCOMCycleCollectionParticipant%3A%3AUnroot(void*)

Firefox 3.1b1 on Mac OS X
bp-38a8e9d8-8398-4b91-acd8-ed6120081119

That's the only one in the recent list with the same end point, but it has a different stack. (no OnItemMoved)
Bugzilla failed to linkify the crash stats URL correctly. Use this instead (if you're too lazy to copy/paste it):  http://tinyurl.com/5tcrms

As of yet, I've been unable to reproduce this using the (latest) STR in any version. However, there's a good chance this is bug 442397 which is bug 454457 which shows the end point as nsNavHistoryResult::OnItemMoved instead of nsXPCOMCycleCollectionParticipant::Unroot. They're both dying at ENUMERATE_ALL_BOOKMARKS_OBSERVERS, so I'm inclined to guess they're the same or at least related.
Duplicate of this bug: 473239
Have ran across the same problem. It happened 3 times in a row as you can see on the times below:

0c244b96-aef5-4bae-968a-b866a2090112	1/12/2009	3:54 PM
7450d558-3db1-4add-9f74-a8d072090112	1/12/2009	3:48 PM
9fe20929-621c-4443-953b-558482090112	1/12/2009	3:42 PM

I created a new folder in the Bookmarks Menu while organizing my bookmarks. While dragging and dropping bookmarks into the newly created folder Firefox crashed. Did the same thing while hovering the bookmark over the new folder to open it before dropping the bookmark in the folder. This too resulted in a crash as soon as the new folder opened.
Same happens to my while running BFTs against Firefox 3.0.6. Here the crash report: bp-5ae65faf-e5d1-4ff1-aea9-dd2312090121

The only thing I did was a d&d of the "Mozilla Firefox" folder above "Recently Bookmarked". Releasing the mouse button let the browser crash. Sorry, but I've no reliable STR.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I call this another bad CC case fixed with bug 487040, hard to verify though, apart no crashes reported in 3.5.x or next versions. 3.0.x is unsupported right now, so I don't think we'll take a fix there.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsXPCOMCycleCollectionParticipant::Unroot - nsNavHistoryResult::OnItemMoved]
You need to log in before you can comment on or make changes to this bug.