The bookmark lable doesn't change after reloading the live title

RESOLVED WONTFIX

Status

Firefox Graveyard
Microsummaries
--
trivial
RESOLVED WONTFIX
10 years ago
3 years ago

People

(Reporter: vicky.sun, Unassigned)

Tracking

3.0 Branch
x86
SunOS

Details

(Whiteboard: [microsummaries-feature-removal], URL)

(Reporter)

Description

10 years ago
This bug can be reproduced on Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9) Gecko/2008071412 Firefox/3.0, but can not on Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.0.2pre) Gecko/2008072401 Minefield/3.0.2pre

Steps to Perform:

   1. Go to this testcase page(http://people.mozilla.com/~myk/microsummaries/tests/generated-microsummary-updates.html) and click the Install Microsummary Generator link.
   2. Press the OK button in the Add Microsummary Generator dialog.
   3. Go to Wikipedia Statistics(http://en.wikipedia.org/wiki/Special:Statistics).
   4. Select Bookmarks | Bookmark This Page to open the Bookmark Properties popup.
   5. Select the numeric live title from the Name editable menu.
   6. Select "Bookmarks Toolbar" from the Folder menu.
   7. Press the Done button.
   8. Navigate away from the Wikipedia Statistics page (i.e. close the tab or go to another page).
   9. Context click the new bookmark in the Bookmarks Toolbar and select "Reload Live Title" from the context menu.

Actual Results: After reloading the live title, the bookmark label doesn't change.
	
Expected Results:

    * After you click the Install Microsummary Generator link, an Add Microsummary Generator dialog should appear asking you to confirm that you want to add a microsummary generator. The dialog should display the "source" (URL) of the microsummary.
    * After you reload the live title, the bookmark label should display a different number.
(Reporter)

Updated

10 years ago
Severity: normal → trivial
(In reply to comment #0)
> Actual Results: After reloading the live title, the bookmark label doesn't
> change.

Hrm, I'm unable to reproduce this result.  After I reload the live title, I see the bookmark label change to a higher number.

Is there anything about your setup (extensions, custom compilation options) that might affect the behavior of this feature?
I see this as well on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090612 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Assignee: nobody → me
Status: NEW → ASSIGNED
OS: SunOS → All
Hardware: x86 → All
Version: 3.0 Branch → Trunk
Woops just grabbed the wrong one, sorry for the spam.
Assignee: me → nobody
Status: ASSIGNED → NEW
OS: All → SunOS
Hardware: All → x86
Version: Trunk → 3.0 Branch
(Reporter)

Comment 4

9 years ago
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1.1) Gecko/20090720 Firefox/3.5.1

Sometimes the case works well, sometimes not. In other words, the bookmark label doesn't always change after reload the live title.
- BUGSPAM -
Wontfixing all Microsummaries bugs, since the feature has been removed from the core product and previous versions won't get further fixes for it.
If interested in supporting Microsummaries in your add-on, you're free to use our old microsummaries code and to search all previously open bugs by looking for [microsummaries-feature-removal] in the status whiteboard field.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: [microsummaries-feature-removal]
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.