Unable to create summary file using pop; onStopRequest not received.

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: pratikd, Assigned: bugzilla)

Tracking

Trunk
mozilla0.9.2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood-] [nsbeta2-][nsbeta3-])

(Reporter)

Description

19 years ago
Using build id: 2000-07-06-08 on Mac (Performance System) 
Speed: 150 mhz, Memory: 64 mb

Steps to reproduce:
1) Launch Mail 
2) Create a test folder in your POP account
3) Copy 5 or more messages in the folder
4) Exit Mail and reopen mail 
5) click on the test folder

Actual: Messages do not appear (summary file not created)
Expected: Messages should appear (summary file should be created)

Note: Tried this on faster MAC using the same build, it works! Also, if summary 
file exists then messages do appear. This bug may be related to bug 20312

Comment 1

19 years ago
Does this happen moving a message?  If it does, and you restart, are those
messages still in your inbox or did you lose them?
(Reporter)

Comment 2

19 years ago
This has nothing to do with moving or copying the message(s) as far as I know. 
In my case, I already had a test folder in my pop account with more than 
5 messages. I deleted the summary file manually, and clicked on the test folder. 
The messages don't appear on the main mail window, the throbber at the bottom 
seems to stall at some random %age points. 

This has blocked most of my performance tests in POP a/c. 


Comment 3

19 years ago
Pratik, does this happen on another mail account(i.e. is this reproduceable on 
all mail accounts).  If this is easily reproduceable, please nominate for 
nsbeta2.
(Reporter)

Comment 4

19 years ago
Bug is easily reproducible on MAC performance system using same NS6 build and 
a different POP a/c. Nominating for nsbeta2.
Keywords: nsbeta2

Comment 5

19 years ago
Putting on [dogfood+][nsbeta2+] radar. 
Keywords: dogfood
Whiteboard: [dogfood+][nsbeta2+]

Comment 6

19 years ago
Why wouldn't summary files be generated on the Mac?  Pratik, what is the entire 
path to your profile on the Mac?  (ie. where the local folders are stored)

Comment 7

19 years ago
Reassiging to ducarroz.  Jean-Francois, can you reproduce this? David, can you
think of a reason why this might happen on the mac?
Assignee: putterman → ducarroz
(Reporter)

Comment 8

19 years ago
Profile Path: mozilla/users50/qatest36/mail/nsmail-5/. Part of the summary file 
resides in the nsmail-5 directory. 

Comment 9

19 years ago
I'm removing the dogfood+ and asking for reconsideration.  I've been asking
around and it looks like the performance machine is the only machine that is
affected by this.  
Whiteboard: [dogfood+][nsbeta2+] → [nsbeta2+]

Comment 10

19 years ago
marking WORKSFORME.  Pratik and I just tried this out on today's build and it no
longer occurs.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 11

19 years ago
mark verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

19 years ago
Bug is back, I can reproduce this on MAC Performance system. 
Using build: 2000-07-20-08. 
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 13

19 years ago
Accepting. Pratik, can you give me the exact step to reproduce this problem 
every time. Thanks
Status: REOPENED → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 14

19 years ago
I can only reproduce this bug on the performance system in the lab. 

Here are the steps again in greater detail:
1) Launch Mail 
2) Create a test folder in your POP account
3) Copy 5 or more messages in the folder (I had 500 messages)
4) Exit Mail 
5) Manually delete the summary file for this folder.
6) reopen mail 
7) click on the test folder

I can reproduce this problem on the performance MAC system only. If you want I 
can show you the bug when you are around. Thanks!~
(Assignee)

Comment 15

19 years ago
When you say "Create a test folder", that means that the name of this folder is 
"test" or "Test"?

I'll come to the office tomorrow to debug this problem on the performance 
machine.
(Reporter)

Comment 16

19 years ago
Make sure you do "Empty Trash" after deleting the summary file, otherwise Mail 
will continue using it. Thats another bug 45449. 
(Reporter)

Comment 17

19 years ago
I meant create any folder and name it what you want. You could also use a folder 
that already exists and which has lots of messages. 
(Assignee)

Comment 18

19 years ago
I am able to reproduce this problem on My Mac with a debug build from yesterday 
using a berkey file (the folder DB) from the Performance Machine which contains 
1000 messages. The summary file start been built but stall at 41%. On the 
Performance machine, it stall at 76%

Comment 19

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  Adding "nsbeta3" keyword 
for consideration of a fix for that milestone. 
Keywords: nsbeta3
Whiteboard: [nsbeta2+] → [nsbeta2-]

Comment 20

19 years ago
adding [dogfood-], please renominate if more people start to see this.  if only 
the perf. machine has this problem, we aren't going to pull pr2 off the wire. - 
PDT
Whiteboard: [nsbeta2-] → [nsbeta2-][dogfood-]
(Assignee)

Comment 21

19 years ago
Looks like a Necko problem. In nsMailboxService.cpp, we correctly 
call RunMailboxUrl(which call LoadUrl), then we reveive a startRequest, some 
OnDataAvailable and then nothing, we never get the onStopRequest!

I cannot attach the file we are trying to parse to this bug report as it might 
contain some personnal emails but I can email it to the person that need it to 
reproduce the problem.

Reassign to necko team.
Assignee: ducarroz → gagan
Status: ASSIGNED → NEW

Comment 22

19 years ago
I don't know if it could happen to other's POP mailboxes. Will keep an eye out
for add'l reports.
Summary: Unable to create summary file in mac using pop → Unable to create summary file in mac using pop; onStopRequest not received.

Comment 23

19 years ago
I like to re-nominated this bug.  I ran into this bug this morning using the Mac 
commercial seamonkey build 2000-072408-m17 on a G3/400 while verifying bug 
26377.  

This problem does not appear to occur on win32 or linux.
Here are the steps I took to reproduce this problem was as follow:
1) Under 4.74 RTM, I logged into a IMAP account.  
2) I created a new folder under the Local Folder server
3) I copied a group of messages from IMAP to my newly created folder
    About 20 messages totaling 7 MB
4) I selected the folder to make sure my messages were copied.
5) Exit Communicator 4.74 RTM

6) If seamonkey is running, exit seamonkey
7) Through the file system, manually copy the the test folder from your 
     HD:System Folder:Preferences:Netscape Users:your_profile:mail
   to your seamonkey folder located in your 
     HD:Documents:Mozilla:Users:your_profile:Mail:Local Folders
8) Start Seamonkey
9) Open Netscape Mail
10) Expand the Local Folders by clicking on the widget
11) Select the mail folder you just transferred
    It starts to build then halts.  

I tried half a dozen time and it stopped building the summary file at different 
percentages.  I finally had to force quit.  It only build the summary file once.

If we don't fix this issue, all the POP users can do is delete the msf summary 
file and hope it builds his summary file.  I don't mind trying to get one folder 
open but if this happens on all the users folders ... heaven help us!

Clearing status whiteboard from: [nsbeta2-][dogfood-]

Please note that very few people within Netscape use POP.  I b/c it too hard to 
maintain mail (read/delete/etc) on multiple machines.
Whiteboard: [nsbeta2-][dogfood-]

Comment 24

19 years ago
Putting on [dogfood-] radar.  Not critical to everyday use. Putting on 
[nsbeta2-] radar. Not critical to beta2. More people need to see this before we 
can do anything about it.  Please see if this is reproducible on other machines.
Whiteboard: [dogfood-] [nsbeta2-]

Comment 25

19 years ago
Can't say if this should be a nsbeta3+ 

->ruslan
Assignee: gagan → ruslan

Updated

19 years ago
Assignee: ruslan → gordon

Comment 26

19 years ago
I don't have MAC to test -> gordon

On the flip side - I don't think on mail protocols we ever send OnStopRequest 
cuz Socketransport is never asked to close the connection. May be it needs to go 
to Waterson?

Comment 27

19 years ago
*** Bug 37046 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Keywords: mailtrack

Comment 28

19 years ago
is this still a prob on mac? (I changed OS version to other not knowing better)
OS: Windows NT → other
Whiteboard: [dogfood-] [nsbeta2-] → [dogfood-] [nsbeta2-][NEED INFO]
(Reporter)

Comment 29

19 years ago
I haven't seen the problem in past couple weeks on MACs!
(Reporter)

Comment 30

19 years ago
I see this bug now on build 2000-08-30-08 M18 on Mac (performance system.)



Comment 31

18 years ago
minus since not a common scenario. 
Status: NEW → ASSIGNED
Whiteboard: [dogfood-] [nsbeta2-][NEED INFO] → [dogfood-] [nsbeta2-][nsbeta3-]

Comment 32

18 years ago
I have not been able to reproduce this bug in today mac commercial seamonkey
build 2000-091904-m18.  It looks like it got fix some how. :)
*** Bug 63780 has been marked as a duplicate of this bug. ***
Since we've had reports of this happening on Win32 as well, I'm changing our
Platform and OS fields to ALL.  I'm still not sure what the summary should
exactly be, but we believe this is a Necko problem.
OS: other → All
Hardware: Macintosh → All
Summary: Unable to create summary file in mac using pop; onStopRequest not received. → Unable to create summary file using pop; onStopRequest not received.

Updated

18 years ago
QA Contact: lchiang → pmock

Updated

18 years ago
Keywords: mailtrack

Comment 35

18 years ago
->dougt for incestigation. 
Assignee: gordon → dougt
Status: ASSIGNED → NEW
Target Milestone: M18 → mozilla0.9.1

Updated

18 years ago
Keywords: nsdogfood-

Updated

18 years ago
Keywords: nsdogfood

Comment 36

18 years ago
Reassigning back to ducarroz.  There is no bustage that I can see which would 
prevent on onStopRequest from going out to the listener.  I am betting this has 
something to do with your mailbox protocol handler.

The URL that gets loaded from LoadUrl, is a mailbox url right?  Quickly looking 
on your nsMailboxProtocol::OnStopRequest, there is an return statement that will 
prevent the listener of LoadURL from receiving the OnStopRequest (line 302).  
Could you try placing a breakpoint in your protocol handler's OnStopRequest to 
see if you are hitting it?

If you believe that this still is a necko/file transport bug, could you please 
attach a nspr log of the nsFileTransport?
Assignee: dougt → ducarroz

Comment 37

18 years ago
Sheela or Stephen, do you still see this?  A lot of POP fixes have gone in since
1/15 when Stephen wrote his comment about others seeing this.

Comment 38

18 years ago
I don't see this on my super-duper machine at home (using AT&T@home's POP3
servers and Win32 build 2001050320).  I have to mention I don't see this when I
tested this briefly yesterday on the Mac in the lab (266 or something). 

Comment 39

18 years ago
moving to 0.9.2, though hopefully this will get a WFM.
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

18 years ago
Keywords: nsenterprise

Comment 40

18 years ago
I'm gong to mark this WFM.
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 41

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.