Closed Bug 448110 Opened 12 years ago Closed 12 years ago

|--disable-svg| does not build

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla1.9.1a2

People

(Reporter: sgautherie, Assigned: sgautherie)

References

Details

Attachments

(2 files, 1 obsolete file)

{{
.../mozilla/content/xbl/src/nsXBLService.cpp(167) :
error C2039: 'generic' : is not a member of 'nsGkAtoms'

...\mozilla\content\base\src\nsGkAtoms.h(49) :
see declaration of 'nsGkAtoms'

.../mozilla/content/xbl/src/nsXBLService.cpp(167) :
error C2065: 'generic' : undeclared identifier

make[6]: *** [nsXBLService.obj] Error 2
}}


Windows 2000: Visual C++ 2005sp1 (Express Ed.) + Platform SDK 2003r2
Current mozilla-central

[
ac_add_options --disable-vista-sdk-requirements
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../../objdir-Firefox
ac_add_options --enable-application=browser

ac_add_options --disable-svg
]

Without the latter option, build completes and runs fine.
Component: XBL → SVG
Flags: in-testsuite-
QA Contact: xbl → general
Summary: "nsXBLService.cpp(167) ... 'generic' : undeclared identifier" caused by |--disable-svg| → |--disable-svg| does not build
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008072618 Minefield/3.1a2pre] (home made) (W2Ksp4)

Fixes comment 0 error.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #331432 - Flags: superreview?(jonas)
Attachment #331432 - Flags: review?(jonas)
Attached patch (Bv1) <nsCSSProps.cpp> (obsolete) — Splinter Review
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008072618 Minefield/3.1a2pre] (home made) (W2Ksp4)

Fixes (next error)
{{
.../mozilla/layout/style/nsCSSProps.cpp(358) :
error C2065: 'eCSSKeyword_round' : undeclared identifier

make[5]: *** [nsCSSProps.obj] Error 2
}}

***

<http://mxr.mozilla.org/comm-central/search?string=eCSSKeyword_round&case=on&find=%2Flayout%2Fstyle%2FnsCSSProps.cpp%24>
{{
/mozilla/layout/style/nsCSSProps.cpp
    * line 358 -- eCSSKeyword_round, NS_STYLE_BORDER_IMAGE_ROUND,
    * line 1078 -- eCSSKeyword_round, NS_STYLE_STROKE_LINECAP_ROUND,
    * line 1085 -- eCSSKeyword_round, NS_STYLE_STROKE_LINEJOIN_ROUND,
}}

The two latters are already in such an |#ifdef|.
Attachment #331434 - Flags: review?(dbaron)
Blocks: 378217
Comment on attachment 331434 [details] [diff] [review]
(Bv1) <nsCSSProps.cpp>

This is the wrong fix.  Instead, you should make the keyword available even when MOZ_SVG is not defined by moving the entry for this keyword in nsCSSKeywordList.h.
Attachment #331434 - Flags: review?(dbaron) → review-
(And I'm not sure why you'd think that disabling one of the values of 'border-image' when SVG was not enabled made any sense.)
Attachment #331432 - Flags: superreview?(jonas)
Attachment #331432 - Flags: superreview+
Attachment #331432 - Flags: review?(jonas)
Attachment #331432 - Flags: review+
Keywords: checkin-needed
Whiteboard: [c-n: Av1 // Leave opened]
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008072701 Minefield/3.1a2pre] (home made) (W2Ksp4)

Bv1, with comment 3 suggestion(s),
plus:
*s/entires/entries/
*s/(name,id)/(name, id)/
*4 white space cleanups

(In reply to comment #4)
> (And I'm not sure why you'd think that disabling one of the values of
> 'border-image' when SVG was not enabled made any sense.)

Only because it compiled (and seemed to run) and I had no other clue...
Attachment #331434 - Attachment is obsolete: true
Attachment #331448 - Flags: review?(dbaron)
Comment on attachment 331448 [details] [diff] [review]
(Cv1) <nsCSSKeywordList.h> (Checkin: Comment 8)

r=dbaron
Attachment #331448 - Flags: review?(dbaron) → review+
Whiteboard: [c-n: Av1 // Leave opened] → [c-n: Av1, Cv1]
Blocks: 448156
Blocks: 448168
Comment on attachment 331432 [details] [diff] [review]
(Av1) <nsXBLService.cpp> (Checkin: Comment 7)

http://hg.mozilla.org/mozilla-central/index.cgi/rev/4dd52626cbe2
Attachment #331432 - Attachment description: (Av1) <nsXBLService.cpp> → (Av1) <nsXBLService.cpp> (Checkin: Comment 7)
Comment on attachment 331448 [details] [diff] [review]
(Cv1) <nsCSSKeywordList.h> (Checkin: Comment 8)

http://hg.mozilla.org/mozilla-central/index.cgi/rev/4dd52626cbe2
Attachment #331448 - Attachment description: (Cv1) <nsCSSKeywordList.h> → (Cv1) <nsCSSKeywordList.h> (Checkin: Comment 8)
Keywords: checkin-needed
Whiteboard: [c-n: Av1, Cv1]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008080208 SeaMonkey/2.0a1pre] (home, debug) (W2Ksp4)

V.Fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.