If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

With norton 360 and after update 07/21/08 no Bookmarks, no History, no Back or Forward buttons, bugs reappear.

RESOLVED DUPLICATE of bug 452469

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 452469
9 years ago
8 years ago

People

(Reporter: Laura Luzius, Unassigned)

Tracking

({dataloss})

3.0 Branch
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: MOST LIKELY DUPE OF 452469)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GoogleT5; SU 3.011; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I have read dozens of pages at the Mozilla Support site, tried various fixes, problems look like resolved, then reappear.

Build Identifier copied and pasted from Help/About appears outdated, says Firefox 3.0.1, yesterday I updated to 3.2.1

I have tried to Uninstall, as well as disable, Add-ons. They will disable, will not uninstall. 

Error messages:

Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBrowserGlue.js :: bg__initPlaces :: line 386"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBrowserGlue.js
Line: 386

Error: uncaught exception: [Exception... "Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDocShellHistory.useGlobalHistory]"  nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)"  location: "JS frame :: chrome://browser/content/browser.js :: prepareForStartup :: line 759"  data: no]

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]
Source File: XStringBundle
Line: 17

Error: uncaught exception: [Exception... "Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDocShellHistory.useGlobalHistory]"  nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)"  location: "JS frame :: chrome://browser/content/browser.js :: prepareForStartup :: line 759"  data: no]

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]
Source File: XStringBundle
Line: 17

Error: [Exception... "'JavaScript component does not have a method named: "onRefreshAttempted"' when calling method: [nsIWebProgressListener2::onRefreshAttempted]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=m85aOXYuwtM&am=R_E4pci3adr3aA :: $NC$ :: line 514"  data: no]
Source File: http://mail.google.com/mail/?ui=2&view=js&name=js&ver=m85aOXYuwtM&am=R_E4pci3adr3aA
Line: 514

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2.
3.
Actual Results:  
Same results

Expected Results:  
Displayed Homepage, Bookmarks, URL in Titlebar,Back/Forward buttons, History

Default theme. 

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=25
(Reporter)

Updated

9 years ago
Keywords: dataloss
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

This works fine for me. Please reinstall Firefox (first delete the contents of the installation folder manually), then start it up with a new profile. You can import one of your bookmarkbackups in this profile.

If the problem reappears after a while then it could be caused by one of your add-ons.

Component: General → Places
QA Contact: general → places
Version: unspecified → 3.0 Branch

Comment 2

9 years ago
I have the exact same Problem on my XP box.
I already tried reinstalling creating new profile and i disabled all add-ons but from time to time my History and Bookmarks are lost and i can't add new ones.
The complete browsing toolbar is fubar'd also and one instance of firefox.exe remains in memory. i'll post some screenshots for now but will come back with a detailed report.

I'm running XP with Firefox German Version

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

This bug is a major issue for me it renders firefox useless!

SCREENS:
http://img179.imageshack.us/my.php?image=magicalsnap200808272121hm8.png
http://img524.imageshack.us/my.php?image=magicalsnap200808272120ek7.png
http://img83.imageshack.us/my.php?image=magicalsnap200808272120jk2.png
http://img403.imageshack.us/img403/3509/magicalsnap200808272121xu6.png

Comment 3

9 years ago
Forgot to say that resetting toolbar options fixes it, but it will happen again at random
So, doing a clean install (uninstall old version, delete programs/mozilla firefox/ folder, install latest version) as suggested by Ria did not fix the issue for both of you?

I see slightly different behaviour reported in comment 2 unless you're getting the same errors in the error console.

as an additional information: what Antivirus/Security software are you running?

Comment 5

9 years ago
No it didn't fix it. I uninstalled completely and deleted all %APPDATA% stuff as well several times.

I was using Norton 360 but removed it yesterday and changed back to AntiVir, i hope this fixes it.
I'm 100% malware free btw.
norton 360 is interesting: see bug 452469 so that could be the cause for you

Comment 7

9 years ago
In removed Norton 360 due to this bug but followed the guideline on configuring 360 before.
however my browser "survived" more starts/shutdowns than before since removal of 360. i hope the best
(Reporter)

Comment 8

9 years ago
"So, doing a clean install (uninstall old version, delete programs/mozilla
firefox/ folder, install latest version) as suggested by Ria did not fix the
issue for both of you?"

I have done all of this repeatedly. Same problem reoccurs.

Comment 9

9 years ago
For me it didn't fix it. I also tried this several times.

However since i removed norton 360 the bug didn't reoccur! I'm bug free for 2 days now. hooray :]

do you run norton 360?
(Reporter)

Comment 10

9 years ago
I do use Norton 360, and since I changed my Firewall settings to allow Firefox, there has been no problem.

It does appear that AdBlocker Plus may be the problem. I did yet another clean install a few days ago, and was having no problem until today, when I installed the AdBlocker Plus add-on. Immediately upon restart of Firefox the Back and Forward buttons on the Navigation Toolbar were greyed out.

I deleted AdBloker Plus and did yet another clean reinstall, and so far, no problem.

Comment 11

9 years ago
I use this addon too but even with all addons disabled the bug occured.
For me configuring norton 360 according to the guideline didn't work.
I think this bug occurs when you change something in your toolbars, like adding new buttons and such.

Updated

9 years ago
Depends on: 452469

Updated

9 years ago
Summary: After update 07/21/08 no Bookmarks, loads blank page instead of Homepage, offers no option to set Homepage, URL in Titlebar does not change, no History, no Back or Forward buttons, bugs reappear after fixed → With norton 360 and after update 07/21/08 no Bookmarks, no History, no Back or Forward buttons, bugs reappear.

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: MOST LIKELY DUPE OF 452469
Marking as Duplicate of Bug 452469 - Laura/Jan maybe the Workarounds in https://wiki.mozilla.org/QA/Firefox3/Investigation/Norton_360 can help you.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452469
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.