bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox does not start following links from external applications

RESOLVED DUPLICATE of bug 395891

Status

()

Toolkit
Startup and Profile System
--
minor
RESOLVED DUPLICATE of bug 395891
10 years ago
10 years ago

People

(Reporter: Jan Janousek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

If Firefox does not run and I follow a link from an external application (e.g. Thunderbird) Firefox does not start properly: it is found in Windows Task Manager but Profile Manager does not appear.

If Firefox runs and I follow a link from an external application (e.g. Thunderbird) Firefox shows the link properly.

Starting Firefox manually works properly: Profile Manager window appears etc.

This behaviour appears after upgrading from Firefox 2.x to Firefox 3.0 and persisted after another upgrade to Firefox 3.0.1.

Reproducible: Always

Steps to Reproduce:
1. Have more than one profile and Profile Manager enabled to appear.
2. Close Firefox if it is running.
3. Follow a link in other application (e.g. Thunderbird).

Actual Results:  
Profile Manager does not appear while a Firefox process appears in Windows Task Manager.

Expected Results:  
Profile Manager should appear to enable to choose a profile and then Firefox should start.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 1

10 years ago
Looks like Bug 312164 which I just added my comment on. See what you think. 
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)

You are almost right. The bug 312164 comment 9 is very right. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395891
You need to log in before you can comment on or make changes to this bug.