Thunderbird guided bug submission form doesn't need a URL field



10 years ago
7 years ago


(Reporter: Richard Mlynarik, Unassigned)






10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv: Gecko/2008070206 Firefox/3.0.1
Build Identifier: 

The default submit-a-Thunderbird bug report form
includes, like the similar browser forms (and like the form I am using
to submit this bug) a field for entering a URL.

I am having a hard time understanding how this could ever be useful for
the mail reader other than in a tiny minority of cases.

What can a URL mean to TB?  If it's the URL for a mail server the odds are
99.99999% that the readers of the bug report don't have access to the server
and account.  If it's the URL for some embedded HTML junk inside a message
then the user ought to be kicked in the head for allowing spamming-enabling
privacy-invading "web bugs".  I just don't see what the use is.

Reproducible: Always

Steps to Reproduce:
1.  Visit
Actual Results:  
Space is consumed by a form field with no practical utility, and one that naive users may feel some sort of obligation to fill with junk.

Expected Results:  
Less text.  Fewer fields!  Fewer electrons wasted transmitting gubbish!
OS: Mac OS X → All
Hardware: Macintosh → All

Comment 1

10 years ago



and various others....
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 2

10 years ago
Reopening.  While timeless is correct that it's occasionally possible to file bugs where a URI is useful in a messaging program, it's not the case for the vast majority of bugs.  Since this is a guided form intended to be used especially by novice users, I agree with the premise of this bug.
Resolution: WONTFIX → ---
"I don't see what the use is" isn't a very strong argument for removing it, especially given timeless' examples of possible uses. It's not clear to me that the benefits to removing it (bug report form simplicity?) outweigh the costs of doing the Bugzilla work to have the field appear per-product.

Comment 4

10 years ago
My gut feeling is that the presence of something that is so rarely used isn't worth the cost in simplicity.  Not sure how I'd quantify that.  

I don't have any idea what the costs in terms of Bugzilla code, UI, and maintainability are.
Costs are low (as low as any bmo-specific hack, that is), since there's already product-specific code in the template, to only auto-fill buildid in browser products.

However, benefits are also quite low: I've been watching every Tb bug for more than a year, and while I see repeated "there's no way to add an attachment in this form" comments, I don't remember once seeing anyone either acting baffled by or annoyed by the URL field.

Certainly some of Thunderbird's 993 (out of 20674 total) bugs with a URL (or at least, one that matches [a-zA-Z], best I could do for searching) are URLs like "does not apply" or "main mail reading page," and almost certainly most of the useful ones, links to RFCs and wikimo pages and MXR searches, come from the non-guided form, so I don't think we'd lose anything by having this, I just don't think the benefit is worth spending ten minutes, hacking on or thinking about. If someone wants to do product-specific hacking on the guided template, hacking at the hot bugs lists would be infinitely more useful.
Summary: Thunderbird bug submission form doesn't need a URL field → Thunderbird guided bug submission form doesn't need a URL field

Comment 6

10 years ago
restoring wontfix. there really are bigger fish to fry, and philor has pointed to a much more interesting one (attachments).
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX


7 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: →
You need to log in before you can comment on or make changes to this bug.