Account field not populated with IMAP4 accounts

VERIFIED FIXED in Thunderbird 3.1b1

Status

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: vouno2002, Assigned: Bienvenu)

Tracking

Thunderbird 3.1b1

Thunderbird Tracking Flags

(thunderbird3.0 .2-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: version 2.0.0.14 (20080421)

TB configured with 2 pop3 and 2 imap4 accounts.
Column "Account" visualized in Main window via "Click to select columns to display" button.
All accounts configured to put mail in account folders and not in local folders.

Messages coming from POP3 account have the account field correctly populated while IMAP4 account have blank Account column.

If move a mail from the inbox folder of the IMAP4 account to a folder in Local Folders, then, when start a reply the account used is the default one and not the account the message belongs to.

Doing the same thing with a message from a POP3 account function correctly.


Reproducible: Always

Steps to Reproduce:
1. Create pop3 account
2. Create imap4 account
3. Show Account field in main window via "Click to select columns to display"
4. Get messages
5. Account field for Imap4 account is empty



Expected Results:  
Correctly populate account field with imap4 account details
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

11 years ago
Confirmed in 2.0.0.16 on a Mac.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
IMAP messages do not have an X-Account-Key header.
Duplicate of this bug: 533473
(In reply to comment #2)
> IMAP messages do not have an X-Account-Key header.
Then is Invalid?
(Assignee)

Comment 5

9 years ago
No, it's relevant now that we have smart mailboxes. But we can only show the account the imap message is in, not the account the message was delivered to initially, which is what we do for pop3 messages.

Comment 6

9 years ago
(In reply to comment #5)

> But we can only show the
> account the imap message is in, not the account the message was delivered to
> initially, which is what we do for pop3 messages.

This would be fine for me. I am using Thunderbird 3.0. Because this new version uses smart folders intensively, it would be great to have this feature added.
(Assignee)

Comment 7

9 years ago
Posted patch proposed fixSplinter Review
Simple fix - unfortunately, it's difficult to add a test for it because nsMsgDBView uses GetIdConst to get the column, which is noscript, which makes it impossible to fake up an nsITreeColumn for testing purposes. We should fix that.
Assignee: nobody → bienvenu
Attachment #416866 - Flags: superreview?(bugzilla)
Attachment #416866 - Flags: review?(bugzilla)
(In reply to comment #0)
> If move a mail from the inbox folder of the IMAP4 account to a folder in Local
> Folders, then, when start a reply the account used is the default one and not
> the account the message belongs to.

It's a variant of phenomenon of bug 327713. As X-Account-Key: is not written upon mail copy from IMAP folder to local mail folder, next happens by current implementation(based on X-Account-Key: header).
  Copy/move to "Local Folders" mail folder :
    Pre-set From: == main identity of default account
  Copy/move to POP3 account's folder :
    Pre-set From: == main identity of the POP3 account
(Assignee)

Updated

9 years ago
Duplicate of this bug: 535748
(Assignee)

Updated

9 years ago
Duplicate of this bug: 535837
(Assignee)

Comment 11

9 years ago
I'd like this for 3.02 at least, since it's a common question on Get Satisfaction...
status-thunderbird3.0: --- → wanted
Comment on attachment 416866 [details] [diff] [review]
proposed fix

>+  nsCOMPtr<nsIMsgAccountManager> accountManager = do_GetService(NS_MSGACCOUNTMANAGER_CONTRACTID, &rv);

nit: please wrap do_GetService to a new line.
Attachment #416866 - Flags: superreview?(bugzilla)
Attachment #416866 - Flags: superreview+
Attachment #416866 - Flags: review?(bugzilla)
Attachment #416866 - Flags: review+
Duplicate of this bug: 541968
(Assignee)

Updated

9 years ago
Attachment #416866 - Flags: approval-thunderbird3.0.2?
(Assignee)

Comment 14

9 years ago
fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b1
Attachment #416866 - Flags: approval-thunderbird3.0.2? → approval-thunderbird3.0.2+
(Assignee)

Updated

9 years ago
status-thunderbird3.0: wanted → .2-fixed
(Assignee)

Comment 15

9 years ago
fixed for 3.02
(Assignee)

Updated

9 years ago
Version: 2.0 → 3.0
(Assignee)

Updated

9 years ago
Duplicate of this bug: 520181
Duplicate of this bug: 503858
Status: RESOLVED → VERIFIED
Keywords: verified-thunderbird3.0
You need to log in before you can comment on or make changes to this bug.