Quicksearch should search classification

RESOLVED DUPLICATE of bug 518024

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 518024
10 years ago
9 years ago

People

(Reporter: jjclark1982, Assigned: reed)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
Created attachment 331807 [details] [diff] [review]
v1

At NASA we moved a grouping from the Product level to the Classification level and users expected to be able to use the quicksearch ":" operator to search Classification.

This patch adds that functionality to the ":" operator if the "useclassification" param is turned on. It will also need documentation.
Attachment #331807 - Flags: review?
Comment on attachment 331807 [details] [diff] [review]
v1

This makes a lot of sense to me; r=Wurblzap by inspection.
Attachment #331807 - Flags: review? → review+
Severity: normal → enhancement
Flags: approval?
OS: Mac OS X → All
Hardware: Macintosh → All
Target Milestone: --- → Bugzilla 3.4

Comment 2

10 years ago
I want the doc at page.cgi?id=quicksearchhack.html and page.cgi?id=quicksearch.html to be fixed too before approving it.
Flags: approval?
Jesse, are you willing to add the additional fixes, and upload a new patch?
(Reporter)

Comment 4

10 years ago
Created attachment 344965 [details] [diff] [review]
v2

Added documentation.
Attachment #331807 - Attachment is obsolete: true
Attachment #344965 - Flags: review?(LpSolit)
Comment on attachment 344965 [details] [diff] [review]
v2

>Index: template/en/default/pages/quicksearchhack.html.tmpl
>===================================================================
>+  <td><tt>classification</tt></td>

You added classification as a field name to documentation but search with this field name doesn't work. You should also add support for "classification:searchword" syntax and possibly even class or clas aliases for it (remember to document these aliases in this page if added).

This is a simple addition to MAPPINS constant at around line 64 and can be done before checkin or in an updated patch so I'll grant a review anyway.
Attachment #344965 - Flags: review?(LpSolit) → review+
Flags: approval?

Comment 6

10 years ago
I first want to see an updated patch. In comment 5, you say that searching with classification doesn't work.
Flags: approval?
Comment on attachment 344965 [details] [diff] [review]
v2

Changing my mind per LpSolit and my previous review comment.
Attachment #344965 - Flags: review+ → review-

Comment 8

10 years ago
too late for 3.4.
Target Milestone: Bugzilla 3.4 → Bugzilla 4.0

Updated

9 years ago
Depends on: 490551
Whiteboard: [needs new patch]

Updated

9 years ago
No longer depends on: 490551
Whiteboard: [needs new patch]

Updated

9 years ago
Depends on: 490551
Whiteboard: [needs new patch]
(Assignee)

Comment 9

9 years ago
Created attachment 411374 [details] [diff] [review]
patch - v3

Ok, how about this? It is untested...
Assignee: jjclark1982 → reed
Attachment #344965 - Attachment is obsolete: true
Attachment #411374 - Flags: review?(mkanat)

Comment 10

9 years ago
This will in fact be resolved by bug 518024.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Depends on: 518293
Resolution: --- → DUPLICATE
Duplicate of bug: 518024

Updated

9 years ago
Attachment #411374 - Flags: review?(mkanat)

Updated

9 years ago
Whiteboard: [needs new patch]
Target Milestone: Bugzilla 4.0 → ---
You need to log in before you can comment on or make changes to this bug.