Closed Bug 448691 Opened 14 years ago Closed 14 years ago

Move "Manage Identities" to Edit menu

Categories

(Thunderbird :: Account Manager, enhancement)

x86
All
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sha256sum, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: 

It is not very logic that Manage Identities are hidden in Account settings.

I therefore propose that is it moved the the Edit menu

See mock up.

Reproducible: Always
Attached image Mock up
I would say that this shouldn't be moved but possibly copied.
Blocks: 448716
The actual problem is to untie "identies" from "accounts" in the UI. Currently, identities are associated with specific accounts, but that's not a limitation imposed by the backend, but just a result of the identity handling evolution.
Identities are stored in mail.identities.* and are referenced by the accounts in mail.account.*.identities. (In theory, you can share identities between accounts, but currently that's only possible by hacking about:config.)

It'd be great to have a central identity UI and then just be able to tell the account "use these identities". But that's a bug already filed, I think. 
No longer blocks: 448716
Whiteboard: dupeme
Blocks: 448716
I do think there's room for a better way to manage identities, but I don't think moving what we currently have to the Edit menu is good progress.

-> WONTFIX
Manage Identities needs some real fixing, but it's so broken right now I don't want to move it forward to the menus before fixing it otherwise.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
(In reply to comment #5)
> Manage Identities needs some real fixing, but it's so broken right now I don't
> want to move it forward to the menus before fixing it otherwise.

One way to deal with Identities is a Tool menu item which would Clone the Account Settings tree. Often Edit as an action is only one activity one can perform with a tool. Create and Delete being the other major activities. This does not justify dumping a tool into the Edit Menu just because a prior action might need an edit some day.

I also will go on record to say this is one of the worst documented features of Mail/News. If I were designing such a new tool, I would build some linked pop up boxes with additional user info into the over all package. 

I support the Wont Fix on this bug.
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.