Closed Bug 448694 Opened 11 years ago Closed 11 years ago

Remove UI for "Remember the last selected message" (mailnews.remember_selected_message)

Categories

(Thunderbird :: Preferences, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: sha256sum, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: 

It is not very logic that "Remember the last selected message" is hidden in the Advanced tab. Compared to the other options in there, this option is no where near "advanced".

I therefore propose that is it moved to Edit->Preferences->Display->General.

See mock up.


Reproducible: Always
Attached image Mock up
Blocks: 448716
IMHO, no need to move this, as it is more advanced, meaning most people won't really want, or care to change. Martin, maybe you should read this: http://www.mozilla.org/projects/firefox/ue/philosophy/realities.html. Though targeted to FF, it applies to TB.
Hardware: PC → All
To Comment #2

It is an interesting read, but seams to deal about selecting good default values.

As the document says "Our users do not want to invest huge amounts of time learning new commands, new and complicated UI, etc.", and Thunderbird really is a nightmere, when it comes to configuration.

E.g. it is very confusing that there are 2 Settings menus; Preferences and Account Settings, that seams to deal with almost the same.

And to top it off, right clicking on the folder pane, gives a menu with many options, and left clicking on an account title gives a new settings page. And from there the Account Settings can also be reached.

I think there is a usability problem here.
I'd agree that we need to remove this option from the ui.  It should be on by default and isn't that useful when turned off.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
Updating summary, completely agree. I don't see the reason anyone wouldn't want this.
Flags: wanted-thunderbird3+
Priority: -- → P4
Summary: Move "Remember the last selected message" to Display → Remove UI for "Remember the last selected message" (mailnews.remember_selected_message)
Whiteboard: [good first bug]
Target Milestone: --- → Thunderbird 3.0b2
The pref has some value with news.  When the pref is true it causes the highlight to not goto the newest header fetched. If anything this is a pref I would rather see being a per-account, or best deal a per-group pref for the News Reader side of Tb.
I don't see that, going into a folder i didn't visit that session no message is selected.
See bug 452440 comment 1 for my thoughts on why this preference shouldn't be necessary.  I think we can remove it and still allow people to have a similar, but better experience.  
(In reply to comment #7)
> I don't see that, going into a folder i didn't visit that session no message is
> selected.
> 

You are right. I also have mailnews.scroll_to_new_message set to false. It looks like what I see is this second pref.  I spent time testing the remember pref and could not see any difference in header list display in the Moz support groups.  It always opened to the top of the list (Order Received, Desending, threaded).




I don't care if you take the preference out of the UI, but I *STRONGLY* do not want to lose the capability.  Message rendering, especially when all or some of the message content is offline, is too slow and, IMO, too distracting.
> I don't care if you take the preference out of the UI, but I *STRONGLY* do not
> want to lose the capability.

This bug shouldn't be removing the preference capability, only the pref UI from the main preferences window.  In fact, in various bugs ( bug 448288 and bug 452440 ) I've talked about how this should be the default.  Even how it should be remembered across sessions.  However I think this preference needs to be displayed and interacted with in a better manner.
Attached patch proposed fixSplinter Review
Remove the UI.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #341693 - Flags: review?(philringnalda)
Whiteboard: [good first bug]
Attachment #341693 - Flags: review?(philringnalda) → review+
changeset:   499:410f5ead898e
http://hg.mozilla.org/comm-central/rev/410f5ead898e

->FIXED
Severity: enhancement → normal
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.