Move "Attachments" to "Copies & Folders"

RESOLVED WONTFIX

Status

Thunderbird
Preferences
--
enhancement
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: Martin, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

91.95 KB, image/png
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: 

Since Thunderbird can handle more than one account, it is not desirable that all attachments are saved in the same folder. It would make more sense to have an attachments folder setting for each account.

Many may (I) have a company account, and a private account, and mixing attachments doesn't seam like a good idea.

In the already Edit->Account Settings->"Copies & Folders" would it fit perfectly.

See mock up.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 331871 [details]
Mock up
(Reporter)

Updated

10 years ago
Blocks: 448716

Comment 2

10 years ago
Just for clarification: You want the download-folder location only moved to the Account Settings, not the Download Actions, correct? Your mock-up shows both. Having separate per-account definitions for the MIME types, and thus multiple mimeTypes.rdf files, would certainly be confusing.
(Reporter)

Comment 3

10 years ago
To Comment #2

That is a very good point you are making. 

I'll update the mock up, so only the "Attachment Folder" is proposed to me moved.

The "Download Actions" should stay.
(Reporter)

Comment 4

10 years ago
Created attachment 332054 [details]
Mock up, with replaces the first.
Attachment #331871 - Attachment is obsolete: true

Comment 5

10 years ago
I still see no sense in moving this. I would not want to change this for EVERY account. Simply set to "Ask every time", and you are set.

Updated

10 years ago
Hardware: PC → All
(Reporter)

Comment 6

10 years ago
I think that would be a very bad "work around" for not moving it.

In my case I have 3 accounts; private, work, and mailinglists. And actually one more for newsgroups.

But I always want to save the "work" attachments in my "work" folder, so they are never mixed with my "private" attachments.

I think Thunderbird should take into account, that a new Account really is a new account, and not have strings and hooks.

Comment 7

10 years ago
I would see both comment #5 and comment #6 as having merit, which brings us back to Martin's general proposal in bug 448716 comment #4 of having a global setting applying to all accounts unless it is overridden by individual settings for a specific account. Thus, having a specific download folder for the work account could be handled separately from an "ask me" global setting, for example. I see a substantial amount of effort necessary though to implement such a scheme for this and the other currently global preferences.

I'm also having a problem with the dual use of the term "Folder" in this case. Generally, in the "Copies & Folders" pane it is related to messages and message folders, whereas the meaning changes in this addition to attachments and target folders in the operating system. This is potentially confusing.

Comment 8

10 years ago
(In reply to comment #7)
> I'm also having a problem with the dual use of the term "Folder" in this case.
> Generally, in the "Copies & Folders" pane it is related to messages and message
> folders, whereas the meaning changes in this addition to attachments and target
> folders in the operating system. This is potentially confusing.

In part We can blame Microsoft for the Folder metaphor driving out the Dir term from Unix and DOS because MS choose to use a Folder icon in the Windows 3 File Manager Dir view.

Comment 9

10 years ago
The code (shared with firefox) doesn't support doing this on an account basis, and I don't see that changing.

What's more, it makes no sense at all to move it under Copies & Folders, as it has absolutely noting to do with that. Besides using the word "folder". C&F is where to put *messages*, the attachment folder is where to put the attachment file *if* you decide to double-click it and after that select Save File in the dialog.

->WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.