Remove "For messages that contain 8-bit..."

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
Preferences
--
enhancement
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Martin, Assigned: rsx11m)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 3
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

4.46 KB, patch
philor
: review+
clarkbw
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: 

Since Thunderbird can handle more than one account, it is not desirable that "For messages that contain 8-bit characters, use 'qouted printable' MIME encoding" is the same for all accounts. It would make more sense to have per account.

I therefore propose it is moved to Edit->"Composition & Addressing".

See mock up.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 331875 [details]
Mock up
(Reporter)

Updated

10 years ago
Blocks: 448716

Comment 2

10 years ago
IMO, zero point having that as an per account setting. In fact, it's questionable to have UI for it at all. (Only needed for testing, for real use it should die die die.)
(Assignee)

Comment 3

10 years ago
I'm wondering how many SMTP servers are still out there which are unable to
process 8-bit content transfer encoding. Thus, I agree with comment #2 that
the relevance of this option for justifying a checkbox in the UI is somewhat questionable, especially given that the description and the implications of
this option are probably not understood by a typical user.

If you want to retain and move it, the Outgoing Server (SMTP) settings would
be more appropriate than the settings of an individual account, as this is a limitation of the SMTP server connected to. But again, I don't really see the need for this effort for an option that likely may retire in the future...

Comment 4

10 years ago
Maybe we should make WONTFIX?
OS: Linux → All
Hardware: PC → All
Whiteboard: [WONTFIX?]
(Reporter)

Comment 5

10 years ago
I would like to see the option gone as well.

So I open a bug 'Remove "For messages that contain 8-bit..."' and close this one, or should this be changed to getting rid of the setting?

Comment 6

10 years ago
I will change it to Remove.
Summary: Move "For messages that contain 8-bit..." to "Composition & Addressing" → Remove "For messages that contain 8-bit..."
Whiteboard: [WONTFIX?]
(Assignee)

Comment 7

10 years ago
Confirming based on several supporting statements, no objections about changing the subject, no duplicate found.
Blocks: 445088
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Attachment #331875 - Attachment is obsolete: true

Comment 8

10 years ago
OK, we can work on removing this from the prefs. Who wants it?
(Assignee)

Comment 9

10 years ago
You can also ask this question the opposite way: Is there any good reason to keep the checkbox for this option? And if yes, does it have to be in the General tab of the Composition preferences?
(In reply to comment #9)
I can not think of a good reason for keeping it. See Comment #2, Comment #3, and Comment #5

Flags: wanted-thunderbird3?
(Assignee)

Comment 11

10 years ago
Tyler, I realize that the comments presented here are all in favor of removing the quoted-printable checkbox (and so am I). However, the fact that neither of us can't think of any reason to keep it doesn't imply that there is none, thus my comment #9 was intended to make sure that we don't miss anything.

I'm working on a patch, should be straightforward.
(Assignee)

Comment 12

10 years ago
Created attachment 333180 [details] [diff] [review]
Proposed patch to remove the checkbox

I can add a screen shot if desired, but the change is rather obvious.
Assignee: nobody → rsx11m.pub
Status: NEW → ASSIGNED
Attachment #333180 - Flags: ui-review?(clarkbw)
Attachment #333180 - Flags: review?(philringnalda)
Comment on attachment 333180 [details] [diff] [review]
Proposed patch to remove the checkbox

excellent! looks good to me
Attachment #333180 - Flags: ui-review?(clarkbw) → ui-review+
(In reply to comment #11)
> Tyler, I realize that the comments presented here are all in favor of removing
> the quoted-printable checkbox (and so am I). However, the fact that neither of
> us can't think of any reason to keep it doesn't imply that there is none, thus
> my comment #9 was intended to make sure that we don't miss anything.
> 
> I'm working on a patch, should be straightforward.
> 

I was just confirming that I could think of no reason to keep.
Attachment #333180 - Flags: review?(philringnalda) → review+
(Assignee)

Comment 15

10 years ago
Thanks for the reviews, check-in/push for comm-central please. 
Keywords: checkin-needed
Checked in, changeset id: 80:027edc78f0da
Flags: wanted-thunderbird3? → in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 3
(Assignee)

Comment 17

10 years ago
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I see the fix.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.