Closed Bug 448989 Opened 11 years ago Closed 11 years ago

Merge mozilla-qt branch into mozilla-central

Categories

(Core Graveyard :: Widget: Qt, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: romaxa, Assigned: romaxa)

References

()

Details

Attachments

(8 files, 2 obsolete files)

Mozilla qt
http://hg.mozilla.org/users/vladimir_mozilla.com/index.cgi/mozilla-qt
port need to be merged into mozilla-central.

See QtPort enabler patch for existing sources.
Attachment #332155 - Flags: review?(vladimir)
Attachment #332156 - Attachment mime type: application/octet-stream → text/plain
Assignee: nobody → romaxa
Comment on attachment 332155 [details] [diff] [review]
QtPort enabler. Diff for existing files

This patch looks fine, are these really the only changes to existing files?  I would've expected changes in nsObjectFrame at least, or are we building with --disable-plugins?
Attachment #332155 - Flags: review?(vladimir) → review+
> would've expected changes in nsObjectFrame at least, or are we building with

We are building with enable-plugins, but actually they are still broken (plugin port not implemented properly).

I hope it will be fixed soon.

Awesome work. Having a nice integration between KDE and firefox would be amazing !
vlad, what is the best way to land this patch?
Commit  "Full patch for Qt port" in one iteration, or commit first patch and push new files after that?
Note, I didn't change anything, just made the patches apply cleanly and separately to XULRunner and Firefox.
Oh well, I couldn't get it to work. :(
Attached patch nsObjectFrame part of qt port (obsolete) — Splinter Review
Attachment #333037 - Flags: review?(vladimir)
DFB has been landed to trunk, therefore created new diff, updated to trunk.
Also added nsObjectFrame fixes.
Attachment #332155 - Attachment is obsolete: true
Attachment #333037 - Attachment is obsolete: true
Attachment #333089 - Flags: review?(vladimir)
Attachment #333037 - Flags: review?(vladimir)
Will this work with 3.0.1?
I think no.
Stuart can you help me with merging Qt branch into mozilla-central?
Do we need to do anything else? Or can you just land that patch? or someone else can do that?

Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
That last patch breaks the qt build (from mozilla-central) for me. It complains with:

gmake[4]: *** No rule to make target `/home/sigma/Develop/Repos/hg/mozilla-central/embedding/browser/qt/tests/Makefile.in', needed by `embedding/browser/qt/tests/Makefile'.  Stop.

Can someone please update the mozconfig at https://wiki.mozilla.org/User:Pjohnsen/MozillaQtBuild to a working configuration?
Depends on: 450936
> needed by `embedding/browser/qt/tests/Makefile'.  Stop.
It is just a bug 450936....


Blocks: 450957
Please add this Qt Instant Messenger
http://retromessenger.sf.net -> Layout
http://retroshare.sf.net -> qt gui and library
https://bugzilla.mozilla.org/show_bug.cgi?id=451565 
Screenshot of latest firefox-qt build in kde 4. Looks really bad for me, even worse than using regular firefox in kde4.
#21 That's because of your theme version is not compatible with your Firefox version. You must deactivate version checking for extensions. Explanation here: http://articles.bluishcoder.co.nz/article/disable-firefox-extension-version-checking/

Appearence still won't be perfect. This is not official but I'm working to make KFirefox fully compatible with it. http://ramonantonio.net/kde-firefox/




I had still no time to report properly some bugs. Here it's what I was investigating:

1. Doubeclick doesn't work in search bar. Doubleclick seems to be correctly launched at widget/src/qt/nsWindow.cpp   nsWindow::mouseDoubleClickEvent but I don't get expected behaviour: getting all text at searchbar selected.

2. Some key events are launched but do not work properly. Those in the class of FunctionKey + ASCIIKey (Ctrl+T for example) do not work properly.
(In reply to comment #22)
> #21 That's because of your theme version is not compatible with your Firefox
> version. You must deactivate version checking for extensions.

Sorry, you're mistaken. What the screenshot in Comment #21 shows is exactly how firefox-qt looks by default, with *no* add-ons/themes. Compile it, move your current ~/.mozilla dir somewhere else, then launch it and you'll see.
don't expect pixel-perfect look from so young port... if you help with bugs - you can expect it faster ;) .
Attachment #333089 - Flags: review?(vladimir)
I've been looking forward to this so much! Previous the use of the GTK theme on KDE unfortunately made Firefox really unusable unless I hacked it severely (black text on black buttons, gray text on dark menus, etc. -- very, very unfriendly to dark color schemes).

However when I tried to run Firefox-qt, I got the following error when using the x86 build.

% ./firefox
./firefox-bin: symbol lookup error: ./libxul.so: undefined symbol: _ZN6QEvent17registerEventTypeEi

Running Suse 10.3, 64-bit processor.

Is a specific version of Qt required? (e.g. 4.??, as perhaps implied by the build instructions)? I ran some random qt* command (qtdoc) and it seems to imply that I have Qt 3.3.8.
Hello people! I'm really interested in using Firefox on Qt/KDE, but the last comment on this bug is almost a year old and this bug is closed "RESOLVED FIXED". If it is fixed then why do we not see a publicly released Qt port of Firefox? 

Are there any issues pending for the Qt port, or has support for this port been dropped? I would like a clarification from the developers on just how far the Qt port has progressed and what the ETA of public binary builds of the Qt port is.

Thanks.
It seems (In reply to comment #26)
> this bug is closed "RESOLVED FIXED".

... because the Qt back-end is now part of the Mozilla toolkit source tree.  Whether Firefox or other Mozilla products are built for Qt or KDE is separate from this bug (it appears the Fennec mobile browser on Maemo can target a Qt backend).  FWIW I filed bug 543912 that http://www.mozilla.org/ports/qtmozilla/ is out-of-date.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.