Last Comment Bug 448989 - Merge mozilla-qt branch into mozilla-central
: Merge mozilla-qt branch into mozilla-central
Status: RESOLVED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Widget: Qt (show other bugs)
: Trunk
: x86 Linux
: -- normal with 27 votes (vote)
: ---
Assigned To: Oleg Romashin (:romaxa)
:
:
Mentors:
http://hg.mozilla.org/users/vladimir_...
Depends on: 450936
Blocks: 450957
  Show dependency treegraph
 
Reported: 2008-08-03 18:41 PDT by Oleg Romashin (:romaxa)
Modified: 2016-07-11 21:54 PDT (History)
44 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
QtPort enabler. Diff for existing files (28.37 KB, patch)
2008-08-03 18:41 PDT, Oleg Romashin (:romaxa)
vladimir: review+
Details | Diff | Splinter Review
List of new files required for QT port (3.82 KB, text/plain)
2008-08-03 18:42 PDT, Oleg Romashin (:romaxa)
no flags Details
Full patch for Qt port (764.28 KB, patch)
2008-08-03 18:51 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review
Patch against Firefox 3.0.1 (621.01 KB, patch)
2008-08-08 16:26 PDT, Luke-Jr
no flags Details | Diff | Splinter Review
Patch against XULRunner 1.9.0.1 (137.23 KB, patch)
2008-08-08 16:26 PDT, Luke-Jr
no flags Details | Diff | Splinter Review
nsObjectFrame part of qt port (6.88 KB, patch)
2008-08-08 17:42 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review
Diff for existing files, updated to trunk + nsObjectFrame (27.20 KB, patch)
2008-08-09 07:10 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review
Full version of latest trunk Qt port. (752.39 KB, patch)
2008-08-09 07:11 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review
Old Embedding API remove (1.61 KB, patch)
2008-08-16 18:55 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review
screenshot of latest firefox-qt build (173.23 KB, image/png)
2008-09-14 14:38 PDT, misha slavin
no flags Details

Description Oleg Romashin (:romaxa) 2008-08-03 18:41:32 PDT
Created attachment 332155 [details] [diff] [review]
QtPort enabler. Diff for existing files

Mozilla qt
http://hg.mozilla.org/users/vladimir_mozilla.com/index.cgi/mozilla-qt
port need to be merged into mozilla-central.

See QtPort enabler patch for existing sources.
Comment 1 Oleg Romashin (:romaxa) 2008-08-03 18:42:31 PDT
Created attachment 332156 [details]
List of new files required for QT port
Comment 2 Oleg Romashin (:romaxa) 2008-08-03 18:51:19 PDT
Created attachment 332157 [details] [diff] [review]
Full patch for Qt port
Comment 3 Vladimir Vukicevic [:vlad] [:vladv] 2008-08-07 10:01:42 PDT
Comment on attachment 332155 [details] [diff] [review]
QtPort enabler. Diff for existing files

This patch looks fine, are these really the only changes to existing files?  I would've expected changes in nsObjectFrame at least, or are we building with --disable-plugins?
Comment 4 Oleg Romashin (:romaxa) 2008-08-07 13:14:00 PDT
> would've expected changes in nsObjectFrame at least, or are we building with

We are building with enable-plugins, but actually they are still broken (plugin port not implemented properly).

I hope it will be fixed soon.

Comment 5 bugzilla.mozilla.org 2008-08-07 16:56:17 PDT
Awesome work. Having a nice integration between KDE and firefox would be amazing !
Comment 6 Oleg Romashin (:romaxa) 2008-08-08 04:58:52 PDT
vlad, what is the best way to land this patch?
Commit  "Full patch for Qt port" in one iteration, or commit first patch and push new files after that?
Comment 7 Luke-Jr 2008-08-08 16:26:22 PDT
Created attachment 333024 [details] [diff] [review]
Patch against Firefox 3.0.1
Comment 8 Luke-Jr 2008-08-08 16:26:44 PDT
Created attachment 333025 [details] [diff] [review]
Patch against XULRunner 1.9.0.1
Comment 9 Luke-Jr 2008-08-08 16:49:53 PDT
Note, I didn't change anything, just made the patches apply cleanly and separately to XULRunner and Firefox.
Comment 10 Luke-Jr 2008-08-08 17:11:52 PDT
Oh well, I couldn't get it to work. :(
Comment 11 Oleg Romashin (:romaxa) 2008-08-08 17:42:45 PDT
Created attachment 333037 [details] [diff] [review]
nsObjectFrame part of qt port
Comment 12 Oleg Romashin (:romaxa) 2008-08-09 07:10:26 PDT
Created attachment 333089 [details] [diff] [review]
Diff for existing files, updated to trunk + nsObjectFrame

DFB has been landed to trunk, therefore created new diff, updated to trunk.
Also added nsObjectFrame fixes.
Comment 13 Oleg Romashin (:romaxa) 2008-08-09 07:11:14 PDT
Created attachment 333090 [details] [diff] [review]
Full version of latest trunk Qt port.
Comment 14 Luke-Jr 2008-08-09 09:40:00 PDT
Will this work with 3.0.1?
Comment 15 Oleg Romashin (:romaxa) 2008-08-09 09:51:33 PDT
I think no.
Comment 16 Oleg Romashin (:romaxa) 2008-08-12 16:11:05 PDT
Stuart can you help me with merging Qt branch into mozilla-central?
Do we need to do anything else? Or can you just land that patch? or someone else can do that?

Comment 17 Oleg Romashin (:romaxa) 2008-08-16 18:55:00 PDT
Created attachment 334134 [details] [diff] [review]
Old Embedding API remove
Comment 18 Yuri Gagarin 2008-08-17 01:17:30 PDT
That last patch breaks the qt build (from mozilla-central) for me. It complains with:

gmake[4]: *** No rule to make target `/home/sigma/Develop/Repos/hg/mozilla-central/embedding/browser/qt/tests/Makefile.in', needed by `embedding/browser/qt/tests/Makefile'.  Stop.

Can someone please update the mozconfig at https://wiki.mozilla.org/User:Pjohnsen/MozillaQtBuild to a working configuration?
Comment 19 Oleg Romashin (:romaxa) 2008-08-17 02:04:48 PDT
> needed by `embedding/browser/qt/tests/Makefile'.  Stop.
It is just a bug 450936....


Comment 20 Mike 2008-08-21 09:00:08 PDT
Please add this Qt Instant Messenger
http://retromessenger.sf.net -> Layout
http://retroshare.sf.net -> qt gui and library
https://bugzilla.mozilla.org/show_bug.cgi?id=451565 
Comment 21 misha slavin 2008-09-14 14:38:37 PDT
Created attachment 338553 [details]
screenshot of latest firefox-qt build

Screenshot of latest firefox-qt build in kde 4. Looks really bad for me, even worse than using regular firefox in kde4.
Comment 22 Ramon Antonio Parada 2008-09-14 14:57:45 PDT
#21 That's because of your theme version is not compatible with your Firefox version. You must deactivate version checking for extensions. Explanation here: http://articles.bluishcoder.co.nz/article/disable-firefox-extension-version-checking/

Appearence still won't be perfect. This is not official but I'm working to make KFirefox fully compatible with it. http://ramonantonio.net/kde-firefox/




I had still no time to report properly some bugs. Here it's what I was investigating:

1. Doubeclick doesn't work in search bar. Doubleclick seems to be correctly launched at widget/src/qt/nsWindow.cpp   nsWindow::mouseDoubleClickEvent but I don't get expected behaviour: getting all text at searchbar selected.

2. Some key events are launched but do not work properly. Those in the class of FunctionKey + ASCIIKey (Ctrl+T for example) do not work properly.
Comment 23 Yuri Gagarin 2008-09-14 15:15:24 PDT
(In reply to comment #22)
> #21 That's because of your theme version is not compatible with your Firefox
> version. You must deactivate version checking for extensions.

Sorry, you're mistaken. What the screenshot in Comment #21 shows is exactly how firefox-qt looks by default, with *no* add-ons/themes. Compile it, move your current ~/.mozilla dir somewhere else, then launch it and you'll see.
Comment 24 Jakub 'Livio' Rusinek 2008-09-14 15:49:28 PDT
don't expect pixel-perfect look from so young port... if you help with bugs - you can expect it faster ;) .
Comment 25 Mats Ahlgren 2008-10-13 16:42:28 PDT
I've been looking forward to this so much! Previous the use of the GTK theme on KDE unfortunately made Firefox really unusable unless I hacked it severely (black text on black buttons, gray text on dark menus, etc. -- very, very unfriendly to dark color schemes).

However when I tried to run Firefox-qt, I got the following error when using the x86 build.

% ./firefox
./firefox-bin: symbol lookup error: ./libxul.so: undefined symbol: _ZN6QEvent17registerEventTypeEi

Running Suse 10.3, 64-bit processor.

Is a specific version of Qt required? (e.g. 4.??, as perhaps implied by the build instructions)? I ran some random qt* command (qtdoc) and it seems to imply that I have Qt 3.3.8.
Comment 26 Shriramana Sharma 2009-09-29 19:37:33 PDT
Hello people! I'm really interested in using Firefox on Qt/KDE, but the last comment on this bug is almost a year old and this bug is closed "RESOLVED FIXED". If it is fixed then why do we not see a publicly released Qt port of Firefox? 

Are there any issues pending for the Qt port, or has support for this port been dropped? I would like a clarification from the developers on just how far the Qt port has progressed and what the ETA of public binary builds of the Qt port is.

Thanks.
Comment 27 skierpage 2010-02-02 22:15:54 PST
It seems (In reply to comment #26)
> this bug is closed "RESOLVED FIXED".

... because the Qt back-end is now part of the Mozilla toolkit source tree.  Whether Firefox or other Mozilla products are built for Qt or KDE is separate from this bug (it appears the Fennec mobile browser on Maemo can target a Qt backend).  FWIW I filed bug 543912 that http://www.mozilla.org/ports/qtmozilla/ is out-of-date.

Note You need to log in before you can comment on or make changes to this bug.