<video> sets mixer volume to 100%

RESOLVED DUPLICATE of bug 448680

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 448680
10 years ago
10 years ago

People

(Reporter: Tim Starling, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008080513 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008080513 Minefield/3.1a2pre

The <video> element sets the mixer volume on the master channel to 100%. It shouldn't. It should leave it the hell alone.

The code makes it look like this is by design: nsOggDecoder initialises mInitialVolume to 1.0, then in nsOggDecoder::OpenAudioStream(), it calls mAudioStream->SetVolume(mInitialVolume). I'm not sure why this is done, but the effect is to blast out whatever rubbish the website autoplays through the speakers as loud as is physically possible. It should be obvious that this will be annoying.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448680
You need to log in before you can comment on or make changes to this bug.