Closed Bug 448680 Opened 11 years ago Closed 11 years ago

Starting <video> playback causes master volume to jump to max

Categories

(Core :: Audio/Video, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: tom, Assigned: cajbir)

References

Details

(Keywords: verified1.9.1)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008073102 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008073102 Minefield/3.1a2pre

Pressing "play" and activating a <canvas> video causes the system's volume to jump to maximum.

Reproducible: Always

Steps to Reproduce:
1. Visit, for example, http://www.double.co.nz/video_test/test1.html
2. Turn your volume down to a sensible level
3. Press a play button
Actual Results:  
Video begins playing with the master volume set to maximum.

Expected Results:  
Video begins playing without changing the system's volume.

Notice that in this case after pausing and resuming the master volume is not affected.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008073103 Minefield/3.1a2pre

My system can't handle it; I only hear creaky unrecognizably deformed sound but not loud. 
I can only hear what it was meant to be when I first close the tab and then the available memory has gone down to 2 MB RAM.
Duplicate of this bug: 448689
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → Trunk
Duplicate of this bug: 449169
This is the first Firefox bug I've read about capable of causing physical harm to users.  It should be fixed ASAP.
Flags: blocking1.9.1?
Summary: Starting <canvas> video playback causes master volume to jump to max → Starting <video> playback causes master volume to jump to max
I assume this is CONFIRMED.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can confirm here with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/20080809020910 Minefield/3.1a2pre
Blocks: video
Duplicate of this bug: 459937
Duplicate of this bug: 460262
Attached patch Fix volume issues (obsolete) — Splinter Review
Removes dead code from nsAudioStream and fixes volume issues related to it. Instead of using hardware volume control support I adjust the sound sample value before writing it. libsydneyaudio has patchy hardware volume control support hence the reason this approach is taken.
Assignee: nobody → chris.double
Status: NEW → ASSIGNED
Attachment #344996 - Flags: superreview?(roc)
Attachment #344996 - Flags: review?(roc)
Comment on attachment 344996 [details] [diff] [review]
Fix volume issues

Move the multiplication by mVolume up inside the floorf, as we discussed.
Attachment #344996 - Flags: superreview?(roc)
Attachment #344996 - Flags: superreview+
Attachment #344996 - Flags: review?(roc)
Attachment #344996 - Flags: review+
Attachment #344996 - Attachment is obsolete: true
Does this also take muting into account? I saw muting the <video> actually muting the whole hardware audio channel, which is the master in my case - and I think we actually should only mute the one <video> this was selected on.
Yes, muting only mutes the current playing video and does not affect the hardware channel in any way.
http://hg.mozilla.org/mozilla-central/rev/5833ad22f1a7
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: blocking1.9.1? → blocking1.9.1+
Keywords: fixed1.9.1
Verified fix on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090217 Shiretoko/3.1b3pre
and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090217 Minefield/3.2a1pre
Status: RESOLVED → VERIFIED
Hey.. I'm using with Nightly version (firefox-nightly 34.0a1.20140722-1), and I get this problem too.

I'm using with GNOME 3.12.2, so what I can to do?
This is a super old bug, and what you are talking about will be fixed real soon, but in the meantime, you can add this to /etc/pulse/daemon.conf:

flat-volumes = no
Hey Paul.
I do what you say and it's fixes my problem. Thank you ! :)
You need to log in before you can comment on or make changes to this bug.