about:config filter with spaces should be treated as a multi-substring search

REOPENED
Unassigned

Status

()

Firefox
Preferences
P5
enhancement
REOPENED
10 years ago
5 months ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/2008080418 Minefield/3.1a2pre

1. Load about:config
2. Type 'triple click'

Result: no hits

Expected: show 'browser.triple_click_selects_paragraph'

I can never remember which prefs are camelCaps or words just smushed together, which use underscores, and which use dots.  Multi-word search would help me a lot.

Updated

9 years ago
Priority: -- → P5
Target Milestone: --- → Future

Comment 1

8 years ago
Created attachment 493759 [details] [diff] [review]
Initial patch proposal

The filter function now checks that every word entered (where words are space-delimited) appears in the preference name/value. The filter text is split by space, and a RegEx is created for each word (just as it was before). A preference matches the filter if it matches every RegEx.
Attachment #493759 - Flags: review?

Updated

7 years ago
Depends on: 687820
OS: Mac OS X → All
Hardware: x86 → All

Comment 2

7 years ago
Right now, spaces are valid characters for configs. https://bugzilla.mozilla.org/show_bug.cgi?id=687820 is looking to change that. Until that is true, searching for a space in the config name may be literal.

Comment 3

7 years ago
As discussed in bug 687820, non alphanumeric characters will continue to be allowed in config names. As a result, multi-substring search won't really make sense since the space character, or any other type of separation character should 'probably' be taken literally.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

7 years ago
I don't agree with the leap from "pref names could, in extremely rare cases, contain spaces" to "spaces in searches should be taken literally".
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 5

7 years ago
Yes, prefs with spaces are the exception and people often want to search for several keywords.
E. g. if you want to search for a Firebug preference, that has something to do with limiting output, you would expect to be able to enter "firebug limit" (without quotes) as every good search engine is doing it.
If somebody really wants to search for an exact string, you could allow to enclose the string in quotes.
(Reporter)

Comment 6

7 years ago
Consider that email subjects and web pages frequently contain spaces, yet searches for those things typically treat spaces specially.

Comment 7

7 years ago
Comment on attachment 493759 [details] [diff] [review]
Initial patch proposal

I probably agree with the above comments. Adding reviewer.
Attachment #493759 - Flags: review? → review?(neil)

Comment 8

7 years ago
Ever since bug 213832 landed it's been possible to use wild cards, so you could have searched for "triple*click" but that wouldn't find preferences whose names included "click" before "triple" or would that not be a problem?

Comment 9

7 years ago
Comment on attachment 493759 [details] [diff] [review]
Initial patch proposal

I think I'm going to have to deny this on the basis that the interaction between spaces and the existing wild card behaviour hasn't been taken into consideration (probably because nobody knew about it...)
Attachment #493759 - Flags: review?(neil) → review-

Comment 10

7 years ago
I really didn't know, that wildcards can be used. This probably already covers most cases. Though obviously the people don't know, that they can use wildcards in the search string. I little hint would help here.
But actually I believe, that separating the keywords by spaces should just replace the '*' wildcard, because it's more intuitive.
Duplicate of this bug: 814925

Comment 12

6 years ago
(In reply to Sebastian Zartner from comment #10)
> But actually I believe, that separating the keywords by spaces should just
> replace the '*' wildcard, because it's more intuitive.

I agree that allowing multiple terms with spaces is more intuitive and expected.
"one*two" (with the wildcard) will not find the entry if the terms are reversed, but allowing spaces for multiple search terms will find it, so the wildcard case is covered. One could argue that using wildcards is more powerfully specific, but in the case of about:config, it's more limiting, making it less likely to allow our target audience to find what they're looking for.
I think that people are coming in with a very google-like (and even thunderbird-like) search expectation.

Also, about spaces, if you're looking for "red ball" (with the space), doing a multi-term search for 'red ball' will always find it. And the about:config list is not that onerous, even if 'ball' & 'red' occur elsewhere, you should be able to easily pick out your desired pref from the couple other hits that come with it.

So I second the motion to consider replacing wildcards with multiple term searches (separated by spaces).

Updated

5 years ago
Duplicate of this bug: 937857
You need to log in before you can comment on or make changes to this bug.