Closed Bug 449466 Opened 13 years ago Closed 13 years ago

[jsd] Extend jsdIDebuggerService to allow changes in the call stack and program counter.

Categories

(Other Applications Graveyard :: Venkman JS Debugger, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 127944

People

(Reporter: johnjbarton, Unassigned)

References

Details

Currently jsdIExecutionHook provide read-only access to the call stack: 
 PRUint32 onExecute ( jsdIStackFrame frame , PRUint32 type , inout jsdIValue val )
To implement full hot-loading support in Firebug we need the ability to reset the stack from and position the program counter.

This could be approached in several ways. We could get some value from simply dropping some stack frames and setting the PC = 0 on the top of the stack then go. This would be pretty good and not at all complicated for the engine or debugger. 

Allowing the debugger to set the stack and pc willy-nilly would be much more fun.

Something in between could be discussed.
Component: General → JavaScript Debugger
Product: Firefox → Other Applications
Version: unspecified → Trunk
generally jsdIDebuggerService only exposes things that jsdebug exposes.

note that it's possible to have:

frame 2
frame 1
c++
frame 0

or something like that. in such a case, it isn't safe to try to change the frame past the first non js frame (1).

basically if you want progress, review jsapi.h and jsdebug.h, and if you can't find a way to do what you want, talk to the owners of spidermonkey and ask them for an api.
QA Contact: general → venkman
Blocks: 486546
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 127944
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.