If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Block [video].play() like we do popup blocking, only user action handler can start play()

RESOLVED WONTFIX

Status

()

Core
Audio/Video
--
enhancement
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User should be able to Globally configure whether to disable autostart on Video/Audio tag.

This also means [video].play() is disabled from script. if script not started by click event, just we disable window.open() in scripts from non click events.

Additionally if a PER WEB SITE Enable/Disable can be done, then it will be cool.
There's a pref to globally disable autoplay now: media.autoplay.enabled, implemented in bug 478982.

Can you please either morph this bug (including bug title) into something covering the other items, or close it as fixed?
(Reporter)

Updated

9 years ago
Summary: About:Config item to disable autostart on Video/Audio tag → Block [video].play() like we do popup blocking, only user action handler can start play()
We can disable autoplay with the pref Matthew pointed out, and we can consider blocking video.play() in future if abuse becomes a problem.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> blocking video.play() in future if abuse becomes a problem.

I dont think waiting to see abuse is a good idea. 
Then it will become a compatibility issue on many site.
I cant see this as WFM, I see WONTFIX as better status for this.
Resolution: WORKSFORME → WONTFIX
Duplicate of this bug: 835453

Updated

5 years ago
Blocks: 86194
You need to log in before you can comment on or make changes to this bug.