Closed Bug 449575 Opened 12 years ago Closed 12 years ago

Menus steal focus hard in Qt port

Categories

(Core Graveyard :: Widget: Qt, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: echidnaman, Assigned: romaxa)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (compatible; Konqueror/4.1; Linux) KHTML/4.1.0 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008080401 Minefield/3.1a2pre

Menus such as the file menu steal focus hard. The only way to lose focus on them and make them go away is to click something on the menu.

Reproducible: Always

Steps to Reproduce:
1. Open The File menu, Edit menu, RSS Live bookmark, whatever.
2. Try clicking anywhere where the menu isn't like on the webpage or your Desktop environment's panel. 
Actual Results:  
Even if you click outside Firefox the menu still doesn't go away.

Expected Results:  
When I click somewhere off the menu the menu should lose focus and disappear.

I am using KDE 4.1.0 and Qt 4.4.1
I'm sure this problem also related to crash in XUL popup windows...
https://bugzilla.mozilla.org/show_bug.cgi?id=449512#c2
Blocks: 449512
Attached patch Bugfix (obsolete) — Splinter Review
Seems Qt::ToolTip widget type is much better for eWindowType_popup.
Attachment #332977 - Flags: review?(vladimir)
Assignee: nobody → romaxa
Also if fixing bug 449512
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: 449823
Add checking for roolup.
Fixed popup menus disappearing on outside clicking (similar to bug 188126)
Attachment #332977 - Attachment is obsolete: true
Attachment #333029 - Flags: review?(pavlov)
Attachment #332977 - Flags: review?(vladimir)
Comment on attachment 333029 [details] [diff] [review]
Added rollup check

If it works, I guess it's fine; I don't know what using the tooltip menu type means on different Qt platforms, so I can see this potentialy breaking somewhere where a tooltip is not just a simple window.
Attachment #333029 - Flags: review?(pavlov) → review+
Qt::Popup grab focus, and it makes things unhappy, especially if you have autocomplete popups...

also it brings too many focus/in/out events (because focus grabbed), and confuse layout.

At least with Qt::ToolTip popups works the same as in GTK build
Fixed:
http://hg.mozilla.org/index.cgi/mozilla-central/rev/9999736a2cf4
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.