4 ways to manipulate bookmaks

VERIFIED DUPLICATE of bug 39332

Status

P3
normal
VERIFIED DUPLICATE of bug 39332
19 years ago
14 years ago

People

(Reporter: mikenjax, Assigned: slamm)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
This is in reference to, and probably dependant on, bug 39332(users 
don't need 2 places to access their bookmarks).

	My bug to report is that users don't need so many ways to manipulate 
their bookmarks, either.

        We currently have 4 ways to do moving and shaking on one's bookmark 
list.   They are the 2 bookmark drop-down-drag-and-drop menus(see bug 39332), 
the bookmark panel on the sidebar, and the manage bookmarks window.  The 
functions of all of these UI elements overlap. Although they all coorespond 
(except the manage bookmarks window) directly to ones in IE, that doesn't mean 
we should have them.

	So, what do we do? Bug 39332 will be resolvd by removing one of the 
drop-down menus, so that leaves two more elements: the sidebar panel and the 
Manage bookmarks window.  We should get rid of one of these as well, as they 
both offer (or will offer) all the bookmark management functions the user 
wants. I suggest the elimination of the manage bookmarks window.  It is big, 
klunky, and unnecessary. 4.x users didn't like having it as their only choice, 
and now that the conveient and stylish sidebar option is there, none of them 
will want to open a separate window to manage their bookmarks.  But we also 
need to give the sidebar panel a little love to make it a worthy replacement. 
This could be done by placing a button at the bottom of the panel to switch 
between a normal veiw and an advanced veiw. Normal veiw would be no different 
than the panel is now. Advanced veiw could show all of the tree columns like in 
the manage bookmarks window, with a horizontal scrollbar to keep the 
information confined to the sidebar panel.

Comment 1

19 years ago
This comment should have belonged with bug 39332, not as a separate bug report.
And also, changing anything as often used as bookmarks _will_ piss off  a lot of
people.

*** This bug has been marked as a duplicate of 39332 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
*** Bug 45022 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.